Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-42686

Can't run any playbook with roles

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Minor
    • Resolution: Not A Defect
    • Component/s: ansible-plugin
    • Labels:
      None
    • Environment:
      Jenkins ver. 2.32.3
      Ansible plugin v0.6.2
      ansible 1.7.2
    • Similar Issues:

      Description

      Maybe this is a known issue, but I can't run any playbook that uses roles.

      It seems like the plugin is somehow finding the role task file and is trying to construct an incorrect path to execute it, instead of the main playbook file.

      Here is a simple reproduction: https://github.com/orzarchi/ansible-plugin-repro

      Here is the pipeline to use with the reproduction: https://raw.githubusercontent.com/orzarchi/ansible-plugin-repro/master/pipeline.txt

      Running it results in the following error:
      [Deploy service] $ ansible-playbook repro.yml -i inventory.ini
      ERROR: file could not read: /var/jenkins_home/workspace/Deploy service/'/var/jenkins_home/workspace/Deploy service/roles/testrole/tasks/main.yml'
      FATAL: command execution failed

        Attachments

          Activity

          scm_issue_link SCM/JIRA link daemon added a comment -

          Code changed in jenkins
          User: Felix Belzunce Arcos
          Path:
          src/main/java/hudson/plugins/active_directory/ActiveDirectoryUnixAuthenticationProvider.java
          src/main/java/hudson/plugins/active_directory/LDAPSearchBuilder.java
          http://jenkins-ci.org/commit/active-directory-plugin/bdcfc6a63f73d344b500627f2db0d982aec7ba54
          Log:
          Merge pull request #67 from fbelzunc/JENKINS-42687

          [FIXED JENKINS-42686] Better handle of PartialResultException

          Compare: https://github.com/jenkinsci/active-directory-plugin/compare/943701dbf3d5...bdcfc6a63f73

          scm_issue_link SCM/JIRA link daemon added a comment -

          Code changed in jenkins
          User: Félix Belzunce Arcos
          Path:
          src/main/java/hudson/plugins/active_directory/ActiveDirectoryUnixAuthenticationProvider.java
          src/main/java/hudson/plugins/active_directory/LDAPSearchBuilder.java
          http://jenkins-ci.org/commit/active-directory-plugin/29bf6c3e4f5b053a308a57553dcae6ae72920645
          Log:
          JENKINS-42686 Better handle of PartialResultException

          orzar or zarchi added a comment -

          Seems like the problem is unrelated to the ansible plugin, running the the playbook command directly as a shell script causes the same error


            People

            • Assignee:
              sirot Jean-Christophe Sirot
              Reporter:
              orzar or zarchi
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: