Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-42710

Update Active Choices DSL to support new secureScript tag (script-security-plugin)

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Minor
    • Resolution: Duplicate
    • Component/s: job-dsl-plugin
    • Labels:
      None
    • Environment:
      Jenkins LTS
      active-choices 1.5.3
      job-dsl 1.58
    • Similar Issues:

      Description

      Hi,

      There syntax of the Active Choices Plug-in changed a little bit since 1.5.x. We are now supporting the script-security-plugin. So now the script is within a <secureScript> tag.

      In the next days I should be able to submit a pull request. Otherwise, if anyone feels like doing it first, feel free to send the PR. I will owe you a beer/coffee

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                daspilker Daniel Spilker
                Reporter:
                kinow Bruno P. Kinoshita
              • Votes:
                0 Vote for this issue
                Watchers:
                1 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: