Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-42744

Environment variables on Windows are all lowercase since 2.50

    Details

    • Similar Issues:

      Description

      Since updating to Jenkins 2.50 ANT builds that use environment variables fail on windows slaves because lots of environment variables are now all lowercase.

      Using environment variables in ANT is case sensitive.

      Variables that come from the system are all lowercase (COMPUTERNAME, Path, SystemDrive, SERVICE_ID, ...) and variables that come from Jenkins are as usual (NODE_NAME, BUILD_ID, ...).

      SERVICE_ID is interesting because it is not set on the system, used to be all uppercase is now also all lowercase.

       SSH Slaves are not affected. Windows slaves use Java Web Start and jenkins-slave.exe as a service.

      Researching I found this which may be related:

      https://social.msdn.microsoft.com/Forums/vstudio/en-US/031707fc-b95d-407c-aadf-5dc1bca69c94/system-variables-lower-case-ant-issue?forum=tfsbuild

        Attachments

          Issue Links

            Activity

            cobexer Ing. Christoph Obexer created issue -
            oleg_nenashev Oleg Nenashev made changes -
            Field Original Value New Value
            Component/s windows-slave-installer-module [ 21834 ]
            oleg_nenashev Oleg Nenashev made changes -
            Labels winsw
            oleg_nenashev Oleg Nenashev added a comment -

            Yes, this is the right root cause. Likely it happens due to the change in WinSW

            oleg_nenashev Oleg Nenashev made changes -
            Labels winsw regression winsw
            oleg_nenashev Oleg Nenashev made changes -
            Priority Major [ 3 ] Critical [ 2 ]
            oleg_nenashev Oleg Nenashev made changes -
            Status Open [ 1 ] In Progress [ 3 ]
            oleg_nenashev Oleg Nenashev made changes -
            Status In Progress [ 3 ] In Review [ 10005 ]
            oleg_nenashev Oleg Nenashev added a comment -

            Created the pull request to WinSW: https://github.com/kohsuke/winsw/pull/202

            Once it gets reviewed and merged, I will update Windows Agent Installer module and the Core

            scm_issue_link SCM/JIRA link daemon added a comment -

            Code changed in jenkins
            User: Oleg Nenashev
            Path:
            CHANGELOG.md
            pom.xml
            http://jenkins-ci.org/commit/windows-slave-installer-module/c614cddeac014ec409f326740f1135f85335eed7
            Log:
            JENKINS-42744 - Update WinSW to 2.0.3

            oleg_nenashev Oleg Nenashev added a comment -
            scm_issue_link SCM/JIRA link daemon added a comment -

            Code changed in jenkins
            User: Oleg Nenashev
            Path:
            CHANGELOG.md
            pom.xml
            http://jenkins-ci.org/commit/windows-slave-installer-module/4a04d4b2b89236fbcaa3347066804d3673ed8ecf
            Log:
            Merge pull request #11 from jenkinsci/winsw/update-2.0.3

            JENKINS-42744 - Update WinSW to 2.0.3

            Compare: https://github.com/jenkinsci/windows-slave-installer-module/compare/3168a2497cdc...4a04d4b2b892

            scm_issue_link SCM/JIRA link daemon added a comment -

            Code changed in jenkins
            User: Oleg Nenashev
            Path:
            core/pom.xml
            war/pom.xml
            http://jenkins-ci.org/commit/jenkins/04e2d33c60f075e133304db2f2e71e037cd5ef9d
            Log:
            JENKINS-42744 - Update WinSW to 2.0.3 and Windows Agent installer to 1.8

            This PR updates WinSW to 2.0.3 in order to fix JENKINS-42744(https://issues.jenkins-ci.org/browse/JENKINS-42744), which is reported as a critical regression in Jenkins 2.50.

            Changelog: https://github.com/kohsuke/winsw/blob/master/CHANGELOG.md#203

            Full diff: https://github.com/kohsuke/winsw/compare/winsw-2.0.2...winsw-2.0.3

            scm_issue_link SCM/JIRA link daemon added a comment -

            Code changed in jenkins
            User: Oleg Nenashev
            Path:
            core/pom.xml
            war/pom.xml
            http://jenkins-ci.org/commit/jenkins/78c5fbcd94cd9a60dd4a9b8a3f71a4239783c9ba
            Log:
            Merge pull request #2826 from oleg-nenashev/windows-slave-installer/1.8

            JENKINS-42744 - Update WinSW to 2.0.3 and Windows Agent installer t0 1.8

            Compare: https://github.com/jenkinsci/jenkins/compare/bde09f70afaf...78c5fbcd94cd

            oleg_nenashev Oleg Nenashev added a comment -

            The fix has been integrated towards 2.53

            oleg_nenashev Oleg Nenashev made changes -
            Status In Review [ 10005 ] Resolved [ 5 ]
            Resolution Fixed [ 1 ]
            nkjensen Niels Kristian Jensen added a comment -

            Great, I'm looking forward to test it soon. Thank you

            jesperjensen Jesper Jensen added a comment -

            Would it be possible to make a guide on how to upgrade both master and windows slaves with this change, somewhat pain less. E.G. where do I find the jenkins-slave.exe and the jenkins.exe so that I can copy them to the correct places?

            nkjensen Niels Kristian Jensen added a comment -

            The problem has been fixed at least since 2.61

            nkjensen Niels Kristian Jensen made changes -
            Status Resolved [ 5 ] Closed [ 6 ]
            jamesdumay James Dumay made changes -
            Remote Link This issue links to "CloudBees Internal OSS-2141 (Web Link)" [ 18404 ]

              People

              • Assignee:
                oleg_nenashev Oleg Nenashev
                Reporter:
                cobexer Ing. Christoph Obexer
              • Votes:
                4 Vote for this issue
                Watchers:
                8 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: