Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-4299

First subversion polls after upgrading to 1.321 fail

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Blocker
    • Resolution: Fixed
    • Component/s: subversion-plugin
    • Labels:
      None
    • Environment:
      Platform: All, OS: Linux
    • Similar Issues:

      Description

      Having upgraded this morning to 1.321, the logs on the master (I have a master /
      two slave setup) were full of:

      http://hudson.pastebin.com/m33e0ce7a

      until I kicked a build off manually, now the errors have stopped (presumably the
      server contains no changes so there is no need to parse the changelog).

      I've just committed some code and the errors are back (SCM poll rate is * * * *

      • so they error once / minute). Re-Saving the config for my changed project
        makes no difference (as suggested by redsolo on IRC)

        Attachments

          Issue Links

            Activity

            olamy Olivier Lamy added a comment -

            Move it to P1 as it's really blocker

            mdonohue mdonohue added a comment -

            It is probably the change Kohsuke made recently that is causing this:
            http://www.nabble.com/Re%3A-svn-connection-from-slave-only-p24985400.html

            abayer Andrew Bayer added a comment -

            It should (theoretically) be fixed in 1.322, I believe - kohsuke just checked in
            a fix to the subversion plugin.

            mdonohue mdonohue added a comment -
                • Issue 4310 has been marked as a duplicate of this issue. ***
            williamleara williamleara added a comment -

            When I click Hudson/Manage Hudson I see this message at the top of the screen:

            "There are more SCM polling activities scheduled than handled, so the threads
            are not keeping up with the demands. Check if your polling isnt hanging, and/or
            increase the number of threads if necessary."

            Is this related to this problem, or is this something different? How would I
            increase the number of threads?

            scm_issue_link SCM/JIRA link daemon added a comment -

            Code changed in hudson
            User: : kohsuke
            Path:
            trunk/hudson/plugins/subversion/pom.xml
            trunk/hudson/plugins/subversion/src/main/java/hudson/scm/SubversionSCM.java
            trunk/hudson/plugins/subversion/src/test/java/hudson/scm/SubversionSCMTest.java
            trunk/hudson/plugins/subversion/src/test/resources/hudson/scm/two-revisions.zip
            http://fisheye4.cenqua.com/changelog/hudson/?cs=21085
            Log:
            [FIXED JENKINS-4299] Fixed a polling on the slave.

            agenticarus agenticarus added a comment -

            Just to confirm, this is now fixed for me - thanks for the quick resolution!

            jbauernberger jbauernberger added a comment -

            We also see this problem in the latest version of hudson. We use cruisecontrol (not SVN).

            thanks,
            joachim

            jpadmana jpadmana added a comment -

            We are seeing the same issue with Hudson 1.353 and Subversion

            Current SCM Polling Activities
            There are more SCM polling activities scheduled than handled, so the threads are not keeping up with the demands. Check if your polling is hanging, and/or increase the number of threads if necessary.

            The following polling activities are currently in progress:

            Can this case be re-opened


              People

              • Assignee:
                Unassigned
                Reporter:
                agenticarus agenticarus
              • Votes:
                0 Vote for this issue
                Watchers:
                1 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: