Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-43039

Blue Ocean Test Results fail to load over https

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Minor
    • Resolution: Fixed
    • Component/s: blueocean-plugin
    • Labels:
      None
    • Environment:
      Jenkins v2.50 (running directly on a server; not containerized)
      Blue Ocean 1.0.0-rc1
      Google Chrome Version 56.0.2924.87 (64-bit)
    • Epic Link:
    • Sprint:
      Blue Ocean 1.0-rc3, Blue Ocean 1.0-rc4
    • Similar Issues:

      Description

      Test results that appear in the old Jenkins UI do not show in the Blue Ocean UI. This appears to be an issue because jenkins is running on https. Going directly to the link that fetch labels as 'Redirect Failed' works.

      Network Layout:

      Internet --> [F5] ---> [Jenkins]

      The F5 manages the SSL certs as well as redirecting to https.

      Below is the output from the chrome console:

      Mixed Content: The page at 'https://jenkins.madmobile.com/blue/organizations/jenkins/Concierge%2FConcierge%20Internal%20Build/detail/Concierge%20Internal%20Build/16/tests' was loaded over HTTPS, but requested an insecure resource 'http://jenkins.madmobile.com/blue/rest/organizations/jenkins/pipelines/Concierge/pipelines/Concierge%20Internal%20Build/runs/16/testReport/result/'. This request has been blocked; the content must be served over HTTPS.
      Fetch API cannot load https://jenkins.madmobile.com/blue/rest/organizations/jenkins/pipelines/Concierge/pipelines/Concierge%20Internal%20Build/runs/16/testReport/result. Redirect failed.
      Mixed Content: The page at 'https://jenkins.madmobile.com/blue/organizations/jenkins/Concierge%2FConcierge%20Internal%20Build/detail/Concierge%20Internal%20Build/16/tests' was loaded over HTTPS, but requested an insecure resource 'http://jenkins.madmobile.com/blue/organizations/jenkins/Concierge%2FConcierge%20Internal%20Build/detail/Concierge%20Internal%20Build/16/tests/'. This request has been blocked; the content must be served over HTTPS.
      

        Attachments

          Activity

          loljs Jonathan Brito created issue -
          loljs Jonathan Brito made changes -
          Field Original Value New Value
          Description Test results that appear in the old Jenkins UI do not show in the Blue Ocean UI. This appears to be an issue because jenkins is running on https. Going directly to the link that fetch labels as 'Redirect Failed' works.

          Network Layout:

          Internet --> [F5] ---> [Jenkins]

          The F5 manages the SSL certs as well as redirecting to https.

          Below is the output from the chrome console:

          {code:java}
          Mixed Content: The page at 'https://jenkins.madmobile.com/blue/organizations/jenkins/Concierge%2FConcierge%20Internal%20Build/detail/Concierge%20Internal%20Build/16/tests' was loaded over HTTPS, but requested an insecure resource 'http://jenkins.madmobile.com/blue/rest/organizations/jenkins/pipelines/Concierge/pipelines/Concierge%20Internal%20Build/runs/16/testReport/result/'. This request has been blocked; the content must be served over HTTPS.
          tests:1 Fetch API cannot load https://jenkins.madmobile.com/blue/rest/organizations/jenkins/pipelines/Concierge/pipelines/Concierge%20Internal%20Build/runs/16/testReport/result. Redirect failed.
          tests:1 Mixed Content: The page at 'https://jenkins.madmobile.com/blue/organizations/jenkins/Concierge%2FConcierge%20Internal%20Build/detail/Concierge%20Internal%20Build/16/tests' was loaded over HTTPS, but requested an insecure resource 'http://jenkins.madmobile.com/blue/organizations/jenkins/Concierge%2FConcierge%20Internal%20Build/detail/Concierge%20Internal%20Build/16/tests/'. This request has been blocked; the content must be served over HTTPS.
          {code}
          Test results that appear in the old Jenkins UI do not show in the Blue Ocean UI. This appears to be an issue because jenkins is running on https. Going directly to the link that fetch labels as 'Redirect Failed' works.

          Network Layout:

          Internet --> [F5] ---> [Jenkins]

          The F5 manages the SSL certs as well as redirecting to https.

          Below is the output from the chrome console:

          {code:java}
          Mixed Content: The page at 'https://jenkins.madmobile.com/blue/organizations/jenkins/Concierge%2FConcierge%20Internal%20Build/detail/Concierge%20Internal%20Build/16/tests' was loaded over HTTPS, but requested an insecure resource 'http://jenkins.madmobile.com/blue/rest/organizations/jenkins/pipelines/Concierge/pipelines/Concierge%20Internal%20Build/runs/16/testReport/result/'. This request has been blocked; the content must be served over HTTPS.
          Fetch API cannot load https://jenkins.madmobile.com/blue/rest/organizations/jenkins/pipelines/Concierge/pipelines/Concierge%20Internal%20Build/runs/16/testReport/result. Redirect failed.
          Mixed Content: The page at 'https://jenkins.madmobile.com/blue/organizations/jenkins/Concierge%2FConcierge%20Internal%20Build/detail/Concierge%20Internal%20Build/16/tests' was loaded over HTTPS, but requested an insecure resource 'http://jenkins.madmobile.com/blue/organizations/jenkins/Concierge%2FConcierge%20Internal%20Build/detail/Concierge%20Internal%20Build/16/tests/'. This request has been blocked; the content must be served over HTTPS.
          {code}
          michaelneale Michael Neale added a comment -

          Hi Jonathan Brito - this is most odd, and certainly not right. 

          We use nginx as LB and it doesn't show this behavior: https://ci.blueocean.io/blue/organizations/jenkins/blueocean/detail/master/795/tests/

          I have not seen this. Is f5 running in http mode that involves URL rewriting? as some services and apps can mess things up that way. 

          Can you check the above link and see that you don't see the mixed content warning? 

          I don't see any content that could be loaded mixed, so there is something else going on somehow... 

          Any other info you can provide about your config? 

          jamesdumay James Dumay added a comment -

          Jonathan Brito If you don't mind capturing a HAR file of the Test page load in Blue Ocean, that could help us diagnose this quicker.

          jamesdumay James Dumay made changes -
          Assignee James Dumay [ jamesdumay ]
          jamesdumay James Dumay made changes -
          Sprint Blue Ocean 1.0-rc2 [ 261 ]
          jamesdumay James Dumay made changes -
          Rank Ranked higher
          jamesdumay James Dumay added a comment -

          Assigning to myself while we investigate

          loljs Jonathan Brito added a comment -

          Michael Neale the above link works as expected. It appears to be trying to load the json representation of the test results: https://jenkins.madmobile.com/blue/rest/organizations/jenkins/pipelines/Concierge/pipelines/Concierge%20Internal%20Build/runs/16/testReport/result/
          James Dumay I will capture a log in a few minutes here.

          loljs Jonathan Brito made changes -
          Attachment jenkins.har [ 36748 ]
          loljs Jonathan Brito added a comment -

          James Dumay HAR file attached

          jamesdumay James Dumay added a comment -

          Jonathan Brito it seems like that HAR file is corrupt. Can you please try to rerecord and upload it again?

          michaelneale Michael Neale added a comment -

          I think har files are best not on a public ticket as it may contain more personal information than should be shared. 

          jamesdumay James Dumay made changes -
          Sprint Blue Ocean 1.0-rc3 [ 261 ] Blue Ocean 1.0-rc3, Blue Ocean 1.0-rc4 [ 261, 281 ]
          jamesdumay James Dumay added a comment -

          Unable to reproduce this with the given information. Please reopen if you can provide more info and thanks for reporting

          jamesdumay James Dumay made changes -
          Status Open [ 1 ] Resolved [ 5 ]
          Resolution Cannot Reproduce [ 5 ]
          jamesdumay James Dumay made changes -
          Epic Link JENKINS-36296 [ 172305 ]
          elatt Erik Lattimore added a comment - - edited

          We have this issue as well. We have Jenkins sitting behind an nginx serving HTTPS for us. I see the same errors in the Chrome console talking about the trying to request information over an insecure resource.

          elatt Erik Lattimore made changes -
          Resolution Cannot Reproduce [ 5 ]
          Status Resolved [ 5 ] Reopened [ 4 ]
          elatt Erik Lattimore added a comment -
          elatt Erik Lattimore added a comment -

          Actually, I believe our nginx configuration was incorrect. I updated the settings to what was on the wiki and we are no longer getting the insecure resource errors and the page now displays.

          elatt Erik Lattimore made changes -
          Status Reopened [ 4 ] Resolved [ 5 ]
          Resolution Fixed [ 1 ]
          jbriden Jenn Briden made changes -
          Status Resolved [ 5 ] Closed [ 6 ]

            People

            • Assignee:
              jamesdumay James Dumay
              Reporter:
              loljs Jonathan Brito
            • Votes:
              0 Vote for this issue
              Watchers:
              4 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: