Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-43065

Task Scanner Plugin - Ignore case broken

    Details

    • Type: Bug
    • Status: Resolved (View Workflow)
    • Priority: Minor
    • Resolution: Cannot Reproduce
    • Component/s: tasks-plugin
    • Labels:
      None
    • Environment:
      Ubuntu Server LTS 2.32.3
      Windows Build Client
      Task Scanner Plugin 4.50
    • Similar Issues:

      Description

      A project with 'todo' lower case in the source code.

      Jenkins configured to scan for 'TODO' upper case but with 'Ignore case' option selected.

      On the project summary page, the graph indicates the correct number of TODO items. When you click on the graph to view the details, all the subsequent views are missing the lower case items.

      As a workaround, I entered 'TODO, todo' in the Task Tags field, but this would miss mixed case in the source.

        Attachments

          Activity

          drulli Ulli Hafner added a comment -

          Can you please add some screenshots or details? Do you mean that the warning is not shown or that the tag is not shown in lowercase?

          I just started the acceptance test https://github.com/jenkinsci/acceptance-test-harness/blob/master/src/test/java/plugins/TaskScannerPluginTest.java#L65 without any problems. Maybe I need some more verifications?

          elzo Erik Newton added a comment -

          I'm really sorry. I can't replicate this now, and looking back at the project where we noticed the problem, I can't see it any more.

          I thought the problem was that the Files tab in the Details section listed 6 items, but the Details tab only listed 4 in total. In this project we had 4 upper case TODOs and 2 lower case. I can only think I had clicked on the New tab by mistake.

          I think it is fine to close this issue.

          Once again I am sorry to waste your time.

          Kind regards,

          Erik

           


            People

            • Assignee:
              drulli Ulli Hafner
              Reporter:
              elzo Erik Newton
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: