Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-43080

java.lang.NullPointerException when Github Branch Source Plugin job executes

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Resolved (View Workflow)
    • Priority: Major
    • Resolution: Incomplete
    • Labels:
      None
    • Environment:
    • Similar Issues:

      Description

      I am having a hard time getting a new setup of the Github Branch Source Plugin executing a build of a candidate branch. This is the output shown below.

      The repository has been scanned successfully and my credentials are in working order.

      This looks like a bug to me.

      The jenkins.log contains only -

      Mar 24, 2017 4:09:45 PM org.jenkinsci.plugins.workflow.job.WorkflowRun finish
      INFO: AndroidSDKs/accounts_android_sdk/develop #13 completed: FAILURE
      Mar 24, 2017 4:09:46 PM org.jenkinsci.plugins.workflow.flow.FlowExecutionList unregister
      WARNING: Owner[AndroidSDKs/accounts_android_sdk/develop/13:AndroidSDKs/accounts_android_sdk/develop #13] was not in the list to begin with: []

      Console Output

       

      Started by user 
       Marcus Greville
       15:35:28 Connecting to https://github.internal/api/v3/ using XXXXXXX/****** (MAGithubScan)GitHub has been notified of this commit's build result
      java.lang.NullPointerException
       at org.kohsuke.github.GitHub.getApiURL(GitHub.java:277)
       at org.kohsuke.github.Requester.asStream(Requester.java:312)
       at org.kohsuke.github.GHContent.read(GHContent.java:119)
       at org.jenkinsci.plugins.github_branch_source.GitHubSCMFile.content(GitHubSCMFile.java:181)
       at jenkins.scm.api.SCMFile.contentAsString(SCMFile.java:338)
       at org.jenkinsci.plugins.workflow.multibranch.SCMBinder.create(SCMBinder.java:91)
       at org.jenkinsci.plugins.workflow.job.WorkflowRun.run(WorkflowRun.java:232)
       at hudson.model.ResourceController.execute(ResourceController.java:97)
       at hudson.model.Executor.run(Executor.java:405)
       Finished: FAILURE
      

       

      The Scan works correctly

      Scan Repository Log

       

      Started by user
      Marcus Greville
      
      [Fri Mar 24 13:51:22 AEDT 2017] Starting branch indexing... 13:51:23 Connecting to https://github.internal/api/v3/ using XXXXXXX/****** (MAGithubScan) Looking up
      MET/accounts_android_sdk
      
      Getting remote pull requests... 0 pull requests were processed Getting remote branches... Checking branch
      develop
      'Jenkinsfile' found
       Met criteria
       Changes detected: develop (55b30a5f68150f6565bcc6ff2b6b0bf0e8a6f418 → 74199dee312697aee68c818d8757cacf3259a8f4)
       Scheduled build for branch: develop
      1 branches were processed
       Done examining MET/accounts_android_sdk
       [Fri Mar 24 13:51:26 AEDT 2017] Finished branch indexing. Indexing took 3.4 sec
       Evaluating orphaned items in Mobile & Emerging Technologies » accounts_android_sdk
       Finished: SUCCESS
      

       

       

        Attachments

          Issue Links

            Activity

            mgreville Marcus Greville added a comment -

            Seeking comments

            padhidipika Dipika Padhi added a comment -

            Hi Team, 

            I ran into the same problem, can someone please address this issue?

             

            stephenconnolly Stephen Connolly added a comment -

            Is this a duplicate of JENKINS-46449?

            stephenconnolly Stephen Connolly added a comment -

            Linking to possible fix/duplicate

            stephenconnolly Stephen Connolly added a comment -

            No response to query if this is a duplicate issue. Assuming it is but marking as incomplete (last comment was a question to the reporter). Please reopen if this is not a duplicate issue


              People

              • Assignee:
                kohsuke Kohsuke Kawaguchi
                Reporter:
                mgreville Marcus Greville
              • Votes:
                1 Vote for this issue
                Watchers:
                4 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: