Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-4310

Build is triggered repetedly for no reason

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Major
    • Resolution: Duplicate
    • Component/s: subversion-plugin
    • Labels:
      None
    • Environment:
      Platform: All, OS: All
    • Similar Issues:

      Description

      I'm running Hudson 1.321 and some of my projects that poll SVN keep being
      rebuilt even though the build pages state "No change".

      The most I've seen is seven rebuilds even though nothing is reported as changed.

      Here is an example from today:

      Build #196 (Aug 25, 2009 2:03:07 PM)
      Revisions
      ...
      No changes.
      A SCM change trigger started this job

      Build #197 (Aug 25, 2009 2:15:23 PM)
      Revisions
      ...
      No changes.
      A SCM change trigger started this job

      Build #198 (Aug 25, 2009 2:31:58 PM)
      Revisions
      ...
      No changes.
      A SCM change trigger started this job

      And it continues like this until build 202, which is the final build until the
      next real SCM change occurred.

      I poll SVN every five minutes with a quiet period of 120 seconds. All jobs run
      on the master, which is a Windows machine.

      I've searched old reports and have found several that resulted in similar
      behavior, but all of the were closed.

        Attachments

          Issue Links

            Activity

            abayer Andrew Bayer added a comment -

            I believe they are related, yes.

            mdonohue mdonohue added a comment -

            Looks like a dup to me.

                • This issue has been marked as a duplicate of 4299 ***
            etomhel etomhel added a comment -

            OK, I've tried 1.322, but it's actually even worse now, so I don't believe that
            this issue is a duplicate of 4299. One of my projects have been stuck in a
            continuous rebuild loop since yesterday, without any changes in the repository.
            I'm switching back to 1.318 again.

            etomhel etomhel added a comment -

            For some reason the SCM polling of a job that is running seems to always report
            that something changed, and the job is scheduled to be built again.

            I don't know it it helps, but here is some output:

            Sep 2, 2009 8:36:50 AM hudson.triggers.SCMTrigger$Runner run
            INFO: SCM changes detected in EWSim_Exp. Triggering #8
            Sep 2, 2009 8:45:32 AM hudson.model.Run run
            INFO: EWSim_Exp #7 main build action completed: SUCCESS
            Sep 2, 2009 8:51:50 AM hudson.triggers.SCMTrigger$Runner run
            INFO: SCM changes detected in EWSim_Exp. Triggering #9
            Sep 2, 2009 8:56:50 AM hudson.triggers.SCMTrigger$Runner run
            INFO: SCM changes detected in EWSim_Exp. Job is already in the queue
            Sep 2, 2009 8:57:12 AM hudson.model.AsyncPeriodicWork$1 run

            etomhel etomhel added a comment -

            OK, I think that this might be a duplicate of 4270. Same symptoms.

            mdonohue mdonohue added a comment -

            Dup

                • This issue has been marked as a duplicate of 4270 ***

              People

              • Assignee:
                Unassigned
                Reporter:
                etomhel etomhel
              • Votes:
                0 Vote for this issue
                Watchers:
                0 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: