Details

    • Type: Improvement
    • Status: Resolved
    • Priority: Major
    • Resolution: Fixed
    • Component/s: nodejs-plugin
    • Labels:
    • Environment:
      I have a master running on intel 64 bit hardware and two slaves, one also running on intel hardware and one running on an armv7l raspberry pi. . All devices are running linux.
    • Similar Issues:

      Description

      I have a tool configuration for NodeJS set up as "node 7.7.4" configured to obtain node automatically from nodejs.org

      I have a jenkinsfile pipeline which declares a tool configuration to use node 7.7.4 at the outermost level.  I then have stages that run on master, the intel slave and finally the raspberry pi slave.  Node is correctly installed from NodeJS on both intel devices during the run of this pipeline.  When it comes to raspberry pi it is unable to find the image, because it is just using "arm" as the  identifier portion to find the binary rather than "armv7l" (or possibly "armv6l" or "arm64")

       

      As a work around I tried setting the specific location of this version of node on the slave nodes configuration ("/home/build/.nvm/versions/node/v7.7.4/bin") but this fails because of JENKINS-43066 

        Attachments

          Activity

            People

            • Assignee:
              nfalco Nikolas Falco
              Reporter:
              akc42 Alan Chandler
            • Votes:
              0 Vote for this issue
              Watchers:
              3 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: