Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-43156

Provide Node and NPM to Path does not work

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Critical
    • Resolution: Fixed
    • Component/s: nodejs-plugin
    • Labels:
      None
    • Environment:
      Jenkins 2.32.3 (LTS)
      a lot of other plugins
      NodeJS Plugin 1.1.3
    • Similar Issues:

      Description

      I have updated the NodeJS Plugin yesterday from version 0.2.2 to 1.1.3 on our Jenkins instance. Afterwards I upgraded Jenkins from 2.32.1 to 2.32.3.

      We have several FreeStyle jobs that are building with Node.js with the following configuration:

      • set up the path with the corresponding Node.js version, using no specific nprmrc file:

      • then have a shell execution build step running some node or npm commands, you could test with
      node -version

      After restart of Jenkins all of our jobs fail, it seems like the plugin is not able to prepare the build environment correctly.

      And here is the console output:

       

        Attachments

          Issue Links

            Activity

            nfalco Nikolas Falco added a comment -

            This sound like duplicate of one of these JENKINS-27170 JENKINS-41762 JENKINS-42323 JENKINS-41857 JENKINS-43066

            Do you have EnvInject plugin installed?
            If yes than you fall in JENKINS-26583

            The workaround reported in our wiki page is remove EnvInject plugin, or make a custom build of workaround-26583 branch. (this branch will never merge into master, it's a EnvInject plugin issue not nodejs)

            krulls Stephan Krull added a comment -

            @Nikolas Falco: OK, sorry for missing the note and all these issues. I can understand your frustration. Will try to build your extra branch.

            jonathonmg Jonathon Golden added a comment -

            FYI, I was able to workaround this issue by putting a dummy nodejs script execution task before the shell task that was executing npm.

            tomerlib tomer liberman added a comment -

            Jonathon Golden 10x! did the trick for me as well


              People

              • Assignee:
                nfalco Nikolas Falco
                Reporter:
                krulls Stephan Krull
              • Votes:
                0 Vote for this issue
                Watchers:
                4 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: