Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-43179

Configuration Empty droplist when adding workspace cleanup include/exclude patterns

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Resolved (View Workflow)
    • Priority: Critical
    • Resolution: Fixed
    • Component/s: ws-cleanup-plugin
    • Labels:
      None
    • Environment:
      Jenkins 2.52
      Workspace Cleanup Plugin 0.32
      Chrome 57.0.2987.110 (64-bit) on Windows 10
    • Similar Issues:

      Description

      Recently while trying to add new jobs, I found that I cannot add include/exclude patterns to
      the workspace cleanup step. The dropdown select box is empty, where it used to have
      INCLUDE/EXCLUDE options.

      For existing jobs, existing pattern entries continue to work, but one cannot add new entries,
      as shown in the attached screenshot.

      There are also 4 javascript errors in the page (domain name obfuscated):

      select.js:8 Uncaught TypeError: Cannot read property 'firstChild' of undefined
       at updateListBox ([https://ci.xxx.xxx/adjuncts/e62d70f0/lib/form/select/select.js:8:67])
       at [https://ci.xxx.xxx/adjuncts/e62d70f0/lib/form/select/select.js:79:13]
       at h ([https://ci.xxx.xxx/static/e62d70f0/scripts/hudson-behavior.js:1294:9])
       at refillOnChange ([https://ci.xxx.xxx/static/e62d70f0/scripts/hudson-behavior.js:1309:5])
       at [https://ci.xxx.xxx/adjuncts/e62d70f0/lib/form/select/select.js:77:9]
       at Array.forEach (native)
       at [https://ci.xxx.xxx/static/e62d70f0/scripts/behavior.js:111:30]
       at Array.forEach (native)
       at [https://ci.xxx.xxx/static/e62d70f0/scripts/behavior.js:107:27]
       at Array.forEach (native)
       select.js:8 Uncaught TypeError: Cannot read property 'firstChild' of undefined
       at updateListBox ([https://ci.xxx.xxx/adjuncts/e62d70f0/lib/form/select/select.js:8:67])
       at [https://ci.xxx.xxx/adjuncts/e62d70f0/lib/form/select/select.js:79:13]
       at h ([https://ci.xxx.xxx/static/e62d70f0/scripts/hudson-behavior.js:1294:9])
       at refillOnChange ([https://ci.xxx.xxx/static/e62d70f0/scripts/hudson-behavior.js:1309:5])
       at [https://ci.xxx.xxx/adjuncts/e62d70f0/lib/form/select/select.js:77:9]
       at Array.forEach (native)
       at [https://ci.xxx.xxx/static/e62d70f0/scripts/behavior.js:111:30]
       at Array.forEach (native)
       at [https://ci.xxx.xxx/static/e62d70f0/scripts/behavior.js:107:27]
       at Array.forEach (native)
       null Failed to load resource: the server responded with a status of 404 (Not Found)
       hudson-behavior.js:2952 Uncaught TypeError: status.firstChild.setAttribute is not a function
       at config.onFailure (select.js:43)
       at klass.respondToReadyState (prototype.js:1657)
       at klass.onStateChange (prototype.js:1600)
       at XMLHttpRequest.<anonymous> (prototype.js:414)
      

        Attachments

          Issue Links

            Activity

            jmellor John Mellor added a comment - - edited

            When constructing a new job, the example is even simpler.  Using Jenkins 2.53 (latest released) and Workspace Cleanup 0.32 (latest released), the include/exclude field cannot be populated.

            marco_rothe Marco Rothe added a comment -

            Same issue here: Select box is empty with Jenkins 2.52 and Workspace Cleanup 0.32 and no configuration can be applied to new jobs.

            olivergondza Oliver Gondža added a comment -

            Fix proposed.

            scm_issue_link SCM/JIRA link daemon added a comment -

            Code changed in jenkins
            User: Oliver Gondža
            Path:
            src/main/java/hudson/plugins/ws_cleanup/Pattern.java
            src/main/resources/hudson/plugins/ws_cleanup/Pattern/config.jelly
            http://jenkins-ci.org/commit/ws-cleanup-plugin/b1c0585d944063c336ab7662b3b084904e886bde
            Log:
            Merge pull request #34 from olivergondza/JENKINS-43179

            [FIXED JENKINS-43179] Get rid of the fragile side-by-side pattern layout

            Compare: https://github.com/jenkinsci/ws-cleanup-plugin/compare/9169aecbc34a...b1c0585d9440


              People

              • Assignee:
                olivergondza Oliver Gondža
                Reporter:
                wens Chen-Yu Tsai
              • Votes:
                3 Vote for this issue
                Watchers:
                6 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: