Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-43231

Running on <node> message not present in Blueocean log

    Details

    • Similar Issues:

      Description

      Using multibranch pipeline on standard Jenkins UI, I am able to see the following message in the "raw" Console Output:

      [Pipeline] node
      Running on slave3 in /home/jenkins/jenkins_slave/workspace/erge_testing_cfg_in_jenkins-MANNGWF53JLLMKMQTLSGC7OKNYH7ODD3C2WLNCPQMYOG7LVTFCRA

      This message is important to me as I use multiple nodes in my pipeline (stages and parallel operation).  If I need to ever drop into the node to debug what is happening, this is a critical piece to troubleshooting.

      Now I will admit that is may not be a blueocean plugin issue but rather more to due with the filtering done during for pipeline builds and its treatment of messages outside of stages and in the more general pipeline context.  My Jenkinsfile is using scripted format and begins as such:

      node {
      
          stage('Download Repo') {
      
              deleteDir()
              git branch: "${BRANCH_NAME}", credentialsId: "$gitCred", url: "git@$gitServer:$gitOrg/repo.git"
      
          }
      
          stage('Download Repo-Templates') {
      <snip>

      In the above example, the pipeline logs for each stage do reflect all the messages within the stage context. 

      So, what improvements can be made with representing log messages that happen outside of a stage/step in the pipeline context in blueocean.

       

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                Unassigned
                Reporter:
                msieger Marc Sieger
              • Votes:
                0 Vote for this issue
                Watchers:
                2 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: