Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-43270

Unable to switch between running parallel nodes in pipeline view

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Major
    • Resolution: Duplicate
    • Component/s: blueocean-plugin
    • Labels:
      None
    • Environment:
      blueocean 1.0.0-rc3
      Jenkins 2.52
    • Similar Issues:

      Description

      When I click on a parallel step "circle" to switch to it, I get the following JavaScript error. It seems to work for completed parallel steps (green checkbox) but not ones currently running (blue circle).

      [ERROR - io.jenkins.blueocean.dashboard.harmonizeTimes] not found any startTime, seems that a component should not have called this me
      error @ blueocean.js:18681
      2blueocean.js:18681 [ERROR - io.jenkins.blueocean.dashboard.harmonizeTimes] not found any startTime, seems that a component should not have called this me
      error @ blueocean.js:18681
      harmonizeTimes @ blueocean.js:7944
      convertJenkinsNodeDetails @ jenkins-js-extension.js:49241
      (anonymous) @ jenkins-js-extension.js:49312
      convertJenkinsNodeGraph @ jenkins-js-extension.js:49311
      processData @ jenkins-js-extension.js:49387
      componentWillReceiveProps @ jenkins-js-extension.js:49378
      updateComponent @ blueocean.js:84564
      receiveComponent @ blueocean.js:84497
      receiveComponent @ blueocean.js:91302
      _updateRenderedComponent @ blueocean.js:84704
      _performComponentUpdate @ blueocean.js:84674
      updateComponent @ blueocean.js:84595
      receiveComponent @ blueocean.js:84497
      receiveComponent @ blueocean.js:91302
      _updateRenderedComponent @ blueocean.js:84704
      _performComponentUpdate @ blueocean.js:84674
      updateComponent @ blueocean.js:84595
      receiveComponent @ blueocean.js:84497
      receiveComponent @ blueocean.js:91302
      performUpdateIfNecessary @ blueocean.js:84509
      performUpdateIfNecessary @ blueocean.js:91334
      runBatchedUpdates @ blueocean.js:92373
      perform @ blueocean.js:94421
      perform @ blueocean.js:94421
      perform @ blueocean.js:92312
      flushBatchedUpdates @ blueocean.js:92395
      close @ blueocean.js:92270
      closeAll @ blueocean.js:94487
      perform @ blueocean.js:94434
      perform @ blueocean.js:92312
      flushBatchedUpdates @ blueocean.js:92395
      closeAll @ blueocean.js:94487
      perform @ blueocean.js:94434
      batchedUpdates @ blueocean.js:88104
      enqueueUpdate @ blueocean.js:92423
      enqueueUpdate @ blueocean.js:92031
      enqueueSetState @ blueocean.js:92216
      ReactComponent.setState @ blueocean.js:83522
      handleChange @ react-redux-4-4-5.js:1924
      dispatch @ blueocean.js:98591
      (anonymous) @ blueocean.js:98102
      dispatch @ blueocean.js:98157
      (anonymous) @ jenkins-js-extension.js:60589
      VM965:1 GET http://jenkins.contextvision.se/blue/rest/organizations/jenkins/pipelines/Bitbucket/honey/branches/PR-45/runs/2/nodes/33/steps//128/log/ 404 (Not Found)
      (anonymous) @ VM965:1
      request @ blueocean.js:2602
      dedupe @ blueocean.js:7854
      dedupe @ blueocean.js:7877
      rawFetch @ blueocean.js:2620
      fetch @ blueocean.js:2695
      fetchLogsInjectStart @ jenkins-js-extension.js:60104
      (anonymous) @ jenkins-js-extension.js:60694
      (anonymous) @ blueocean.js:98099
      (anonymous) @ blueocean.js:98178
      componentWillMount @ jenkins-js-extension.js:52194
      performInitialMount @ blueocean.js:84303
      mountComponent @ blueocean.js:84210
      mountComponent @ blueocean.js:91223
      updateChildren @ blueocean.js:82488
      _reconcilerUpdateChildren @ blueocean.js:90076
      _updateChildren @ blueocean.js:90175
      updateChildren @ blueocean.js:90162
      _updateDOMChildren @ blueocean.js:85920
      updateComponent @ blueocean.js:85738
      receiveComponent @ blueocean.js:85696
      receiveComponent @ blueocean.js:91302
      _updateRenderedComponent @ blueocean.js:84704
      _performComponentUpdate @ blueocean.js:84674
      updateComponent @ blueocean.js:84595
      receiveComponent @ blueocean.js:84497
      receiveComponent @ blueocean.js:91302
      updateChildren @ blueocean.js:82476
      _reconcilerUpdateChildren @ blueocean.js:90076
      _updateChildren @ blueocean.js:90175
      updateChildren @ blueocean.js:90162
      _updateDOMChildren @ blueocean.js:85920
      updateComponent @ blueocean.js:85738
      receiveComponent @ blueocean.js:85696
      receiveComponent @ blueocean.js:91302
      _updateRenderedComponent @ blueocean.js:84704
      _performComponentUpdate @ blueocean.js:84674
      updateComponent @ blueocean.js:84595
      receiveComponent @ blueocean.js:84497
      receiveComponent @ blueocean.js:91302
      _updateRenderedComponent @ blueocean.js:84704
      _performComponentUpdate @ blueocean.js:84674
      updateComponent @ blueocean.js:84595
      performUpdateIfNecessary @ blueocean.js:84511
      performUpdateIfNecessary @ blueocean.js:91334
      runBatchedUpdates @ blueocean.js:92373
      perform @ blueocean.js:94421
      perform @ blueocean.js:94421
      perform @ blueocean.js:92312
      flushBatchedUpdates @ blueocean.js:92395
      closeAll @ blueocean.js:94487
      perform @ blueocean.js:94434
      batchedUpdates @ blueocean.js:88104
      enqueueUpdate @ blueocean.js:92423
      enqueueUpdate @ blueocean.js:92031
      enqueueSetState @ blueocean.js:92216
      ReactComponent.setState @ blueocean.js:83522
      handleChange @ react-redux-4-4-5.js:1924
      dispatch @ blueocean.js:98591
      (anonymous) @ blueocean.js:98102
      dispatch @ blueocean.js:98157
      (anonymous) @ jenkins-js-extension.js:60641
      jenkins-js-extension.js:60722 error Error: Not Found
      at checkStatus (blueocean.js:2417)
      (anonymous) @ jenkins-js-extension.js:60722
      (anonymous) @ blueocean.js:2513

        Attachments

          Issue Links

            Activity

            jamesdumay James Dumay added a comment -

            Emil Styrke thanks for reporting this. We are about to land a more comprehensive change here that will fix the problem you are describing. I believe this is a duplicate of both JENKINS-42312 and JENKINS-42547. Watch both of these tickets for updates

            estyrke Emil Styrke added a comment -

            It seems you're right. Thanks!


              People

              • Assignee:
                Unassigned
                Reporter:
                estyrke Emil Styrke
              • Votes:
                0 Vote for this issue
                Watchers:
                2 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: