Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-43393

Intermittent "Inflater has been closed" errors

    Details

    • Type: Bug
    • Status: Resolved (View Workflow)
    • Priority: Minor
    • Resolution: Duplicate
    • Component/s: maven-plugin
    • Labels:
    • Environment:
    • Similar Issues:

      Description

      I am getting intermittently failing maven jobs failing with an "Inflater has been closed" error.

      This occurs immediately after checkout from subversion.

      A typical trace is:
       

      ERROR: Processing failed due to a bug in the code. Please report this to jenkinsci-users@googlegroups.com
      {{[java.lang.NullPointerException|http://stacktrace.jenkins-ci.org/search?query=java.lang.NullPointerException]}}
      : Inflater has been closed
      	at 
      {{[java.util.zip.Inflater.ensureOpen(Inflater.java:389)|http://stacktrace.jenkins-ci.org/search/?query=java.util.zip.Inflater.ensureOpen&entity=method]}}
      	at 
      {{[java.util.zip.Inflater.inflate(Inflater.java:257)|http://stacktrace.jenkins-ci.org/search/?query=java.util.zip.Inflater.inflate&entity=method]}}
      	at 
      {{[java.util.zip.InflaterInputStream.read(InflaterInputStream.java:152)|http://stacktrace.jenkins-ci.org/search/?query=java.util.zip.InflaterInputStream.read&entity=method]}}
      	at 
      {{[java.io.FilterInputStream.read(FilterInputStream.java:107)|http://stacktrace.jenkins-ci.org/search/?query=java.io.FilterInputStream.read&entity=method]}}
      	at 
      {{[java.util.Properties$LineReader.readLine(Properties.java:435)|http://stacktrace.jenkins-ci.org/search/?query=java.util.Properties$LineReader.readLine&entity=method]}}
      	at 
      {{[java.util.Properties.load0(Properties.java:353)|http://stacktrace.jenkins-ci.org/search/?query=java.util.Properties.load0&entity=method]}}
      	at 
      {{[java.util.Properties.load(Properties.java:341)|http://stacktrace.jenkins-ci.org/search/?query=java.util.Properties.load&entity=method]}}
      	at 
      {{[hudson.maven.MavenEmbedderUtils.getMavenVersion(MavenEmbedderUtils.java:217)|http://stacktrace.jenkins-ci.org/search/?query=hudson.maven.MavenEmbedderUtils.getMavenVersion&entity=method]}}
      	at 
      {{[hudson.maven.MavenVersionCallable.call(MavenVersionCallable.java:69)|http://stacktrace.jenkins-ci.org/search/?query=hudson.maven.MavenVersionCallable.call&entity=method]}}
      	at 
      {{[hudson.maven.MavenVersionCallable.call(MavenVersionCallable.java:41)|http://stacktrace.jenkins-ci.org/search/?query=hudson.maven.MavenVersionCallable.call&entity=method]}}
      	at 
      {{[hudson.FilePath.act(FilePath.java:1084)|http://stacktrace.jenkins-ci.org/search/?query=hudson.FilePath.act&entity=method]}}
      	at 
      {{[hudson.maven.MavenModuleSetBuild$MavenModuleSetBuildExecution.doRun(MavenModuleSetBuild.java:642)|http://stacktrace.jenkins-ci.org/search/?query=hudson.maven.MavenModuleSetBuild$MavenModuleSetBuildExecution.doRun&entity=method]}}
      	at 
      {{[hudson.model.AbstractBuild$AbstractBuildExecution.run(AbstractBuild.java:534)|http://stacktrace.jenkins-ci.org/search/?query=hudson.model.AbstractBuild$AbstractBuildExecution.run&entity=method]}}
      	at 
      {{[hudson.model.Run.execute(Run.java:1735)|http://stacktrace.jenkins-ci.org/search/?query=hudson.model.Run.execute&entity=method]}}
      	at 
      {{[hudson.maven.MavenModuleSetBuild.run(MavenModuleSetBuild.java:544)|http://stacktrace.jenkins-ci.org/search/?query=hudson.maven.MavenModuleSetBuild.run&entity=method]}}
      	at 
      {{[hudson.model.ResourceController.execute(ResourceController.java:97)|http://stacktrace.jenkins-ci.org/search/?query=hudson.model.ResourceController.execute&entity=method]}}
      	at 
      {{[hudson.model.Executor.run(Executor.java:405)|http://stacktrace.jenkins-ci.org/search/?query=hudson.model.Executor.run&entity=method]}}
      project=hudson.maven.MavenModuleSet@2c805c09[Liferay-Prereg Email Tasks - PreregPTAdmEmail LIVE]
      project.getModules()=[hudson.maven.MavenModule@1857417e[Liferay-Prereg Email Tasks - PreregPTAdmEmail LIVE/uk.ac.sheffield.cics.liferay:liferay-prereg-email-tasks][Liferay-Prereg Email Tasks - PreregPTAdmEmail LIVE/uk.ac.sheffield.cics.liferay:liferay-prereg-email-tasks][relativePath:]]
      project.getRootModule()=hudson.maven.MavenModule@1857417e[Liferay-Prereg Email Tasks - PreregPTAdmEmail LIVE/uk.ac.sheffield.cics.liferay:liferay-prereg-email-tasks][Liferay-Prereg Email Tasks - PreregPTAdmEmail LIVE/uk.ac.sheffield.cics.liferay:liferay-prereg-email-tasks][relativePath:]
      FATAL: Inflater has been closed
      {{[java.lang.NullPointerException|http://stacktrace.jenkins-ci.org/search?query=java.lang.NullPointerException]}}
      : Inflater has been closed
      	at 
      {{[java.util.zip.Inflater.ensureOpen(Inflater.java:389)|http://stacktrace.jenkins-ci.org/search/?query=java.util.zip.Inflater.ensureOpen&entity=method]}}
      	at 
      {{[java.util.zip.Inflater.inflate(Inflater.java:257)|http://stacktrace.jenkins-ci.org/search/?query=java.util.zip.Inflater.inflate&entity=method]}}
      	at 
      {{[java.util.zip.InflaterInputStream.read(InflaterInputStream.java:152)|http://stacktrace.jenkins-ci.org/search/?query=java.util.zip.InflaterInputStream.read&entity=method]}}
      	at 
      {{[java.io.FilterInputStream.read(FilterInputStream.java:107)|http://stacktrace.jenkins-ci.org/search/?query=java.io.FilterInputStream.read&entity=method]}}
      	at 
      {{[java.util.Properties$LineReader.readLine(Properties.java:435)|http://stacktrace.jenkins-ci.org/search/?query=java.util.Properties$LineReader.readLine&entity=method]}}
      	at 
      {{[java.util.Properties.load0(Properties.java:353)|http://stacktrace.jenkins-ci.org/search/?query=java.util.Properties.load0&entity=method]}}
      	at 
      {{[java.util.Properties.load(Properties.java:341)|http://stacktrace.jenkins-ci.org/search/?query=java.util.Properties.load&entity=method]}}
      	at 
      {{[hudson.maven.MavenEmbedderUtils.getMavenVersion(MavenEmbedderUtils.java:217)|http://stacktrace.jenkins-ci.org/search/?query=hudson.maven.MavenEmbedderUtils.getMavenVersion&entity=method]}}
      	at 
      {{[hudson.maven.MavenVersionCallable.call(MavenVersionCallable.java:69)|http://stacktrace.jenkins-ci.org/search/?query=hudson.maven.MavenVersionCallable.call&entity=method]}}
      	at 
      {{[hudson.maven.MavenVersionCallable.call(MavenVersionCallable.java:41)|http://stacktrace.jenkins-ci.org/search/?query=hudson.maven.MavenVersionCallable.call&entity=method]}}
      	at 
      {{[hudson.FilePath.act(FilePath.java:1084)|http://stacktrace.jenkins-ci.org/search/?query=hudson.FilePath.act&entity=method]}}
      	at 
      {{[hudson.maven.MavenModuleSetBuild$MavenModuleSetBuildExecution.doRun(MavenModuleSetBuild.java:642)|http://stacktrace.jenkins-ci.org/search/?query=hudson.maven.MavenModuleSetBuild$MavenModuleSetBuildExecution.doRun&entity=method]}}
      	at 
      {{[hudson.model.AbstractBuild$AbstractBuildExecution.run(AbstractBuild.java:534)|http://stacktrace.jenkins-ci.org/search/?query=hudson.model.AbstractBuild$AbstractBuildExecution.run&entity=method]}}
      	at 
      {{[hudson.model.Run.execute(Run.java:1735)|http://stacktrace.jenkins-ci.org/search/?query=hudson.model.Run.execute&entity=method]}}
      	at 
      {{[hudson.maven.MavenModuleSetBuild.run(MavenModuleSetBuild.java:544)|http://stacktrace.jenkins-ci.org/search/?query=hudson.maven.MavenModuleSetBuild.run&entity=method]}}
      	at 
      {{[hudson.model.ResourceController.execute(ResourceController.java:97)|http://stacktrace.jenkins-ci.org/search/?query=hudson.model.ResourceController.execute&entity=method]}}
      	at 
      {{[hudson.model.Executor.run(Executor.java:405)|http://stacktrace.jenkins-ci.org/search/?query=hudson.model.Executor.run&entity=method]}}
      
        
      

        Attachments

          Issue Links

            Activity

            mlynnyk Mykola Lynnyk added a comment - - edited

            I have encountered this issue and investigated it. The problem has been introduced in maven-plugin-2.15.1 and I believe it to be caused by the fix for defect JENKINS-40621 . The recent change in lib-jenkins-maven-embedder altered the way how Maven version is verified on slaves, and it appears to be less stable. Downgrading maven-plugin to 2.14 (und thus to lib-jenkins-maven-embedder-3.11) fixes the problem.

            One more important note - in addition to the exception in the defect description ("Inflater has been closed"), the following trace is generated under exactly the same circumstance by the same portion of code, just a few lines earlier (MavenEmbedderUtils.java:213 instead of MavenEmbedderUtils.java:217):

             

            java.lang.IllegalStateException: zip file closed
            	at java.util.zip.ZipFile.ensureOpen(Unknown Source)
            	at java.util.zip.ZipFile.getEntry(Unknown Source)
            	at java.util.jar.JarFile.getEntry(Unknown Source)
            	at sun.net.www.protocol.jar.URLJarFile.getEntry(Unknown Source)
            	at java.util.jar.JarFile.getJarEntry(Unknown Source)
            	at hudson.maven.MavenEmbedderUtils.getMavenVersion(MavenEmbedderUtils.java:213)
            	at hudson.maven.MavenVersionCallable.call(MavenVersionCallable.java:69)
            	at hudson.maven.MavenVersionCallable.call(MavenVersionCallable.java:41)
            	at hudson.remoting.UserRequest.perform(UserRequest.java:153)
            	at hudson.remoting.UserRequest.perform(UserRequest.java:50)
            	at hudson.remoting.Request$2.run(Request.java:332)
            	at hudson.remoting.InterceptingExecutorService$1.call(InterceptingExecutorService.java:68)
            	at java.util.concurrent.FutureTask.run(Unknown Source)
            	at java.util.concurrent.ThreadPoolExecutor.runWorker(Unknown Source)
            	at java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source)
            	at hudson.remoting.Engine$1$1.run(Engine.java:90)
            	at java.lang.Thread.run(Unknown Source)
            	at ......remote call to BUILDBOX(Native Method)
            	at hudson.remoting.Channel.attachCallSiteStackTrace(Channel.java:1433)
            	at hudson.remoting.UserResponse.retrieve(UserRequest.java:253)
            	at hudson.remoting.Channel.call(Channel.java:797)
            	at hudson.FilePath.act(FilePath.java:1102)
            	at hudson.maven.MavenModuleSetBuild$MavenModuleSetBuildExecution.doRun(MavenModuleSetBuild.java:642)
            	at hudson.model.AbstractBuild$AbstractBuildExecution.run(AbstractBuild.java:534)
            	at hudson.model.Run.execute(Run.java:1720)
            	at hudson.maven.MavenModuleSetBuild.run(MavenModuleSetBuild.java:544)
            	at hudson.model.ResourceController.execute(ResourceController.java:98)
            	at hudson.model.Executor.run(Executor.java:404)
            

             


              People

              • Assignee:
                Unassigned
                Reporter:
                siwilkins Simon Wilkins
              • Votes:
                2 Vote for this issue
                Watchers:
                5 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: