Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-43446

java.lang.NoSuchFieldError: DEFAULT_USER_SETTINGS_FILE

    Details

    • Type: Bug
    • Status: Resolved (View Workflow)
    • Priority: Blocker
    • Resolution: Fixed
    • Component/s: maven-plugin
    • Labels:
      None
    • Environment:
      Jenkins 2.46.1
      Maven 3.5.0
    • Similar Issues:

      Description

      Hi, after upgrading Maven to the latest version, 3.5.0, the following error occurs during a build of a maven job:

       
      Executing Maven: -B -f [...]/pom.xml install
      java.lang.reflect.InvocationTargetException
      at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
      at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)
      at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
      at java.lang.reflect.Method.invoke(Method.java:498)
      at org.codehaus.plexus.classworlds.launcher.Launcher.launchStandard(Launcher.java:330)
      at org.codehaus.plexus.classworlds.launcher.Launcher.launch(Launcher.java:238)
      at jenkins.maven3.agent.Maven33Main.launch(Maven33Main.java:176)
      at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
      at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)
      at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
      at java.lang.reflect.Method.invoke(Method.java:498)
      at hudson.maven.Maven3Builder.call(Maven3Builder.java:139)
      at hudson.maven.Maven3Builder.call(Maven3Builder.java:70)
      at hudson.remoting.UserRequest.perform(UserRequest.java:153)
      at hudson.remoting.UserRequest.perform(UserRequest.java:50)
      at hudson.remoting.Request$2.run(Request.java:336)
      at hudson.remoting.InterceptingExecutorService$1.call(InterceptingExecutorService.java:68)
      at java.util.concurrent.FutureTask.run(FutureTask.java:266)
      at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1142)
      at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:617)
      at java.lang.Thread.run(Thread.java:745)
      Caused by: java.lang.NoSuchFieldError: DEFAULT_USER_SETTINGS_FILE
      at org.apache.maven.cli.DefaultMavenExecutionRequestBuilder.settings(DefaultMavenExecutionRequestBuilder.java:658)
      at org.apache.maven.cli.DefaultMavenExecutionRequestBuilder.getMavenExecutionRequest(DefaultMavenExecutionRequestBuilder.java:149)
      at org.jvnet.hudson.maven3.launcher.Maven33Launcher.getMavenExecutionRequest(Maven33Launcher.java:150)
      at org.jvnet.hudson.maven3.launcher.Maven33Launcher.main(Maven33Launcher.java:127)
      ... 21 more
       

       

        Attachments

          Issue Links

            Activity

            aheritier Arnaud Héritier added a comment -

            perfect. Thx laurent perez

            aheritier Arnaud Héritier added a comment -

            Hi laurent perez could you open another case please with more details about Jenkins core + plugins used and if possible a project to reproduce it.

            Your issue seems valid but completely different from this one.

            Thanks

            laurentperez laurent perez added a comment -

            Hi. This plugin upgrade seems to have broken CPD/PMD plugins. Jenkins 2.4.x, since switching to plugin 2.16

            The NPEe were already there before 2.16, but now the build really fails.
            [PMD] Successfully parsed file /root/.jenkins/workspace/common/common-dep/libcti-java-plugin/target/pmd.xml of module libcti-java-plugin with 0 unique warnings and 0 duplicates.
            java.io.EOFException
            at java.io.DataInputStream.readInt(DataInputStream.java:392)
            at java.io.ObjectInputStream$BlockDataInputStream.readInt(ObjectInputStream.java:2827)
            at java.io.ObjectInputStream.readInt(ObjectInputStream.java:971)
            at com.google.common.collect.Serialization.readCount(Serialization.java:50)
            DRY] Successfully parsed file /root/.jenkins/workspace/exemplejar/target/cpd.xml of module exemplejar with 461 unique warnings and 0 duplicates.
            java.io.EOFException
            at java.io.DataInputStream.readInt(DataInputStream.java:392)
            at java.io.ObjectInputStream$BlockDataInputStream.readInt(ObjectInputStream.java:2827)
            at java.io.ObjectInputStream.readInt(ObjectInputStream.java:971)
            at com.google.common.collect.Serialization.readCount(Serialization.java:50)

            aheritier Arnaud Héritier added a comment -

            released in 2.16. Thx Olivier Lamy


              People

              • Assignee:
                tcohen Tomer Cohen
                Reporter:
                jhack Giacomo Boccardo
              • Votes:
                30 Vote for this issue
                Watchers:
                42 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: