Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-43499

Windows Installers (and other) with Embedded Java should use Java 8

    Details

    • Type: Bug
    • Status: Fixed but Unreleased (View Workflow)
    • Priority: Minor
    • Resolution: Fixed
    • Component/s: packaging
    • Labels:
      None
    • Similar Issues:

      Description

      Follow-up to JENKINS-43492

      We need to ensure that all packages ship Java 8 if they do embed it. From what I see, at least some tests (e.g. openSuse) run with Java 7 and hence will probably become unstable. Windows installer definitely bundles Java, we need to ensure the version is correct (Java 8 latest, 32 bit)

        Attachments

          Issue Links

            Activity

            oleg_nenashev Oleg Nenashev created issue -
            oleg_nenashev Oleg Nenashev made changes -
            Field Original Value New Value
            Description Follow-up to JENKINS-43492 Follow-up to JENKINS-43492

            We need to ensure that all packages ship Java 8 if they do embed it. From what I see, at least some tests (e.g. openSuse) run with Java 7 and hence will probably become unstable. Windows installer definitely bundles Java, we need to ensure the version is correct (Java 8 latest, 32 bit)
            oleg_nenashev Oleg Nenashev made changes -
            Summary Jenkins Windows Installer should use Java 8 Jenkins Installers with Embedded Java should use Java 8
            oleg_nenashev Oleg Nenashev made changes -
            Link This issue is related to JENKINS-43492 [ JENKINS-43492 ]
            oleg_nenashev Oleg Nenashev made changes -
            Summary Jenkins Installers with Embedded Java should use Java 8 Windows Installers (and other) with Embedded Java should use Java 8
            oleg_nenashev Oleg Nenashev made changes -
            Assignee Kohsuke Kawaguchi [ kohsuke ]
            oleg_nenashev Oleg Nenashev made changes -
            Epic Link JENKINS-43500 [ 180815 ]
            millda4 Dave Miller added a comment -

            When I try to install the new version 2.55, I get the same 503 "Service Unavailable" error that I received when trying to install version 2.54.  I have to revert back to 2.53 to get Jenkins to work.  The server where Jenkins is installed has Java 8 on it.

             

             

             C:\>java -version
            java version "1.8.0_74"
            Java(TM) SE Runtime Environment (build 1.8.0_74-b02)
            Java HotSpot(TM) 64-Bit Server VM (build 25.74-b02, mixed mode)

             

            Jenkins was installed by somebody else who is no longer with our company, so I "inherited" the setup.  It was installed as a service that gets automatically started every time that server is rebooted.  From the jenkins.err.log file, I see:

            Caused by: java.lang.UnsupportedClassVersionError: jenkins/util/SystemProperties : Unsupported major.minor version 52.0

            Am I missing something here?  What is going wrong?  I thought version 2.55 was created to solve the problem of Jenkins using its own internal version of Java 7 instead of the server's Java 8 version.

            mindeb Mindaugas Batutis added a comment -

            I just had this issue and solved it by:

            1. Creating JAVA_HOME environment variable to point to Java 8 directory, i.e. C:\Program Files (x86)\Java\jre1.8.0_111\bin
            2. Editing C:\Program Files (x86)\Jenkins\jenkins.xml line <executable>...</executable> to <executable>%JAVA_HOME%\java</executable>
            3. Opening command line in C:\Program Files (x86)\Jenkins and running "jenkins stop", "jenkins uninstall", "jenkins install", "jenkins start".

            I also deleted the jre folder from Jenkins directory just to be sure. Hope this helps until the above issue is resolved.

            oleg_nenashev Oleg Nenashev added a comment -

            Dave Miller Make sure your Jenkins version uses the same JDK. By default the windows installer uses the bundled version. As Mindaugas Batutis mentioned above (bullet #2), you can check it in the Windows Service Wrapper config file (jenkins.xml)

            oleg_nenashev Oleg Nenashev added a comment -

            It was resolved at some point. The next step for Platform SIG is to get rid of Java bundling in the installer at all. Alex Earl is working on it afaik

            oleg_nenashev Oleg Nenashev made changes -
            Status Open [ 1 ] Fixed but Unreleased [ 10203 ]
            Resolution Fixed [ 1 ]

              People

              • Assignee:
                Unassigned
                Reporter:
                oleg_nenashev Oleg Nenashev
              • Votes:
                1 Vote for this issue
                Watchers:
                4 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: