Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-43517

CLI requests a passphrase when run in default http mode

    Details

    • Type: Bug
    • Status: Open (View Workflow)
    • Priority: Minor
    • Resolution: Unresolved
    • Component/s: cli, core
    • Labels:
      None
    • Environment:
      Jenkins >=2.54
    • Similar Issues:

      Description

      When run using the default http protocol, if the Jenkins CLI finds there is an SSH key in the user's home directory which requires a passcode, it will prompt for that passcode. It should not be doing this.

        Attachments

          Issue Links

            Activity

            Hide
            jglick Jesse Glick added a comment -

            Seems to have always been true: happens even in older versions of Jenkins when using, say, --password. Just more noticeable now.

            Workaround is to explicitly pass -noKeyAuth if you know you have a private key in the default location (~/.ssh/id_[rd]sa) with a passphrase.

            Show
            jglick Jesse Glick added a comment - Seems to have always been true: happens even in older versions of Jenkins when using, say, --password . Just more noticeable now. Workaround is to explicitly pass -noKeyAuth if you know you have a private key in the default location ( ~/.ssh/id_ [rd] sa ) with a passphrase.

              People

              • Assignee:
                Unassigned
                Reporter:
                kshultz Karl Shultz
              • Votes:
                0 Vote for this issue
                Watchers:
                2 Start watching this issue

                Dates

                • Created:
                  Updated: