Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-43600

Artifacts cannot be accessed when pipeline is paused for input or executing

    Details

    • Sprint:
      Blue Ocean - 1.1-beta-1
    • Similar Issues:

      Description

      Problem
      Artifacts cannot be accessed when pipeline is paused for input or executing

      Original description
      This is also true of the classic build page, but artifacts do not display until after the Pipeline has completed. However, the main project page does dynamically show the artifacts dynamically on specific builds while they are still running. I would even be satisfied if I could see the artifacts as they are collected by having to refresh the page but having to wait until the build completes is problematic for pipelines that have approval phases because I have a case where earlier in the pipeline, it generates output that a human can examine and decide whether or not to approve the build based on this artifact.

        Attachments

          Activity

          elatt Erik Lattimore created issue -
          jamesdumay James Dumay made changes -
          Field Original Value New Value
          Issue Type Improvement [ 4 ] Bug [ 1 ]
          jamesdumay James Dumay added a comment -

          Erik Lattimore thanks for reporting. I can confirm this is a bug.

          jamesdumay James Dumay made changes -
          Status Open [ 1 ] In Progress [ 3 ]
          jamesdumay James Dumay made changes -
          Status In Progress [ 3 ] In Review [ 10005 ]
          jamesdumay James Dumay made changes -
          Epic Link JENKINS-35750 [ 171713 ]
          jamesdumay James Dumay made changes -
          Summary It would be nice if the Artifacts page updated dynamically during a Pipeline job Artifacts cannot be accessed when pipeline is paused for input or executing
          Description This is also true of the classic build page, but artifacts do not display until after the Pipeline has completed. However, the main project page does dynamically show the artifacts dynamically on specific builds while they are still running. I would even be satisfied if I could see the artifacts as they are collected by having to refresh the page but having to wait until the build completes is problematic for pipelines that have approval phases because I have a case where earlier in the pipeline, it generates output that a human can examine and decide whether or not to approve the build based on this artifact. *Problem*
          Artifacts cannot be accessed when pipeline is paused for input or executing

          *Original description*
          This is also true of the classic build page, but artifacts do not display until after the Pipeline has completed. However, the main project page does dynamically show the artifacts dynamically on specific builds while they are still running. I would even be satisfied if I could see the artifacts as they are collected by having to refresh the page but having to wait until the build completes is problematic for pipelines that have approval phases because I have a case where earlier in the pipeline, it generates output that a human can examine and decide whether or not to approve the build based on this artifact.
          Sprint Blue Ocean - techdebt sprint 1 [ 291 ]
          jamesdumay James Dumay made changes -
          Assignee James Dumay [ jamesdumay ]
          jamesdumay James Dumay added a comment -

          Erik Lattimore it seems there isn't a way to tap into Jenkins events for the archiving of artifacts. Ive opened this up so you can browse the artifact list while the pipeline is waiting for input or is executing.

          jamesdumay James Dumay made changes -
          Status In Review [ 10005 ] Resolved [ 5 ]
          Resolution Fixed [ 1 ]
          elatt Erik Lattimore added a comment -

          I'm a little confused, is this a fixed or a won't fix resolution? If it requires more plumbing from core, I would still prefer rather than closing this bug, moving it to a feature request because I feel there is some value in being able to fetch artifacts from a build when we are waiting at an input step. It is also curious that the main project page dynamically updates its artifact list per-build.

          jamesdumay James Dumay added a comment -

          Erik Lattimore we fixed this in Blue Ocean 1.1 which is due out next week

          elatt Erik Lattimore added a comment -

          Awesome, thanks guys.

          jbriden Jenn Briden made changes -
          Status Resolved [ 5 ] Closed [ 6 ]

            People

            • Assignee:
              jamesdumay James Dumay
              Reporter:
              elatt Erik Lattimore
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: