Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-43729

Slave-agent.jnlp does not obey httpPort or httpsPort settings

    Details

    • Type: Bug
    • Status: Resolved (View Workflow)
    • Priority: Major
    • Resolution: Not A Defect
    • Component/s: core
    • Environment:
      Windows: variety of versions
      Jenkins: 2.46.1
    • Similar Issues:

      Description

      Problem

      It doesn't matter what settings are passed in to Jenkins on the command line (i.e.--httpPort=8001 --httpsPort=8002) the slave-agent.jnlp file refers to port 8010, as do the instructions on the Node page.

      At the moment it's impossible to run a web-started node over https, or when Jenkins is running on a non-standard port.

      Expected behaviour

      If https is enabled then the instructions (and jnlp file) should all point to https, using the port set on the command line.  If not then the instructions (and jnlp file) should all point to http, using the port set on the command line.

        Attachments

          Issue Links

            Activity

            oleg_nenashev Oleg Nenashev added a comment -

            As designed, I'd say. Jenkins relies on the URL specified in the Global system configuration. The Port from command line cannot be used, because in such case there may be issues with proxy setups (e.g. haproxy or Docker port mapping).

            theandrewducker Andrew Ducker added a comment -

            Aaah!  Thank you!  I had no idea that that was where it was getting that information from.  Updating that setting meant that I can now connect over HTTPS.

            oleg_nenashev Oleg Nenashev added a comment -

            Thanks for the confirmation! Closing as "Not a defect" then

            theandrewducker Andrew Ducker added a comment -

            Would it be possible to update the help text for that setting to mention that it also covers the Java Webstart settings.

             

            And/or getting this added to https://wiki.jenkins-ci.org/display/JENKINS/Starting+and+Accessing+Jenkins ?

            oleg_nenashev Oleg Nenashev added a comment -

            Updated tge Wiki: https://wiki.jenkins-ci.org/pages/diffpages.action?pageId=42469975&originalId=116097132 . Which help text would you expect to be changed?


              People

              • Assignee:
                oleg_nenashev Oleg Nenashev
                Reporter:
                theandrewducker Andrew Ducker
              • Votes:
                0 Vote for this issue
                Watchers:
                2 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: