Details

    • Similar Issues:
    • Epic Link:

      Description

      We are at about react 15.3. 

      The latest is 15.5 which has some deprecation warnings and some minor breaking change regaring how things are packaged up (ie an extra import needed): 

      https://facebook.github.io/react/blog/2017/04/07/react-v15.5.0.html

      We should investigate the impact of this on all the plugins (and editor), and take note of deprecation warnings as this is preparing the way for v16 (react fibre) which likely will be a very good but big upgrade (and probably one we sit with for a while). 

      I expect we could settle on a tempo of 1 react upgrade per year (whcih seems their tempo for "not small" upgrades). 

       

      The result of this is not necessarily an upgrade in the time of 1.1.

        Attachments

          Issue Links

            Activity

            There are no comments yet on this issue.

              People

              • Assignee:
                cliffmeyers Cliff Meyers
                Reporter:
                michaelneale Michael Neale
              • Votes:
                0 Vote for this issue
                Watchers:
                1 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: