Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-43989

CLI error after upgrading to 2.46.2: ERROR: anonymous is missing the Overall/Read permission

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Major
    • Resolution: Not A Defect
    • Component/s: cli
    • Labels:
      None
    • Environment:
      Jenkins 2.46.2
    • Similar Issues:

      Description

      When we upgraded from 2.32.3 to 2.46.2, this command started failing:

      $ java -jar jenkins-cli.jar -noCertificateCheck -i /tmp/jenkins_id_rsa -s http://myjenkins:8080/ groovy /tmp/my.groovy
      May 02, 2017 10:01:48 AM hudson.cli.CLI _main
      INFO: Skipping HTTPS certificate checks altogether. Note that this is not secure at all.
      
      ERROR: anonymous is missing the Overall/Read permission
      

      Note: we are passing in a id_rsa file, so anonymous should not be in the picture at all.

        Attachments

          Activity

          grayaii Alex Gray added a comment -

          This may be a dupe of https://issues.jenkins-ci.org/browse/JENKINS-34375, but since I'm using id_rsa as authentication, it is probably different.

          grayaii Alex Gray added a comment - - edited

          Oh wait. I now have to add "-remoting" to the command line and make sure "Enable CLI over Remoting" is checked in the "Configure Global Security" page of Jenkins.

          Closing ticket.


            People

            • Assignee:
              oleg_nenashev Oleg Nenashev
              Reporter:
              grayaii Alex Gray
            • Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: