Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-44021

Issue with HP Application Automation Tools plugin

    Details

    • Similar Issues:

      Description

      I am trying to utilize HP Application Automation Tools plugin to connect to ALM QC server from Jenkins to execute testscripts created as VAPI-XP-TEST. But I am not seeing "Running Tests Sets from ALM" at options and when I am trying with Running Performance Tests using HP Performance Center option it doesnt work. 

      Also when I am using this plugin some of my other builds failing with below error. Someone could help me to fix these issues?

      I am mainly looking for pipeline script options.
      java.lang.NullPointerException
      at com.hp.application.automation.tools.octane.events.SCMListenerImpl.onChangeLogParsed(SCMListenerImpl.java:84)

        Attachments

          Activity

          Hide
          xiwenhpe xiwen zhao added a comment -

          Hi Joseph,

          Could you please try to run test without Jenkins? Launch UFT on your windows slave, run a test on ALM see if it gets same error.

          Thanks

          Show
          xiwenhpe xiwen zhao added a comment - Hi Joseph, Could you please try to run test without Jenkins? Launch UFT on your windows slave, run a test on ALM see if it gets same error. Thanks
          Hide
          xiwenhpe xiwen zhao added a comment -

          Confirmed with ALM team, OTA must match server version.

          Open ALM on your slave machine, click "Tools", click "HP ALM Client Registration", click "Register HP ALM"

          It should solve your problem.

          Show
          xiwenhpe xiwen zhao added a comment - Confirmed with ALM team, OTA must match server version. Open ALM on your slave machine, click "Tools", click "HP ALM Client Registration", click "Register HP ALM" It should solve your problem.
          Hide
          yafim_kazak Yafim Kazak added a comment -

          Hi Eldo Joseph,
          please confirm if this resolves this issue and close the ticket if it does.
          Thanks.

          Show
          yafim_kazak Yafim Kazak added a comment - Hi Eldo Joseph , please confirm if this resolves this issue and close the ticket if it does. Thanks.
          Hide
          eldojoseph1234 Eldo Joseph added a comment -

          Yafim Kazak, sorry issue is still there. We tried after doing Register process. We are getting a different error now.

           
          HpToolsLauncher.exe -paramfile props26052017111301608.txt
          "Started..."
          Timeout is set to: 60
          Run mode is set to: RUN_PLANNED_HOST
          ============================================================================
          Starting test set execution
          Test set name: SmokeTestSuite, Test set id: 2551
          Could not create scheduler, please verify ALM client installation on run machine by downloading and in installing the add-in form:
          http://higalmqcenter/qcbin//TDConnectivity_index.html

           

          We tried installing TDConnectivity_index.html but not working.

          Show
          eldojoseph1234 Eldo Joseph added a comment - Yafim Kazak , sorry issue is still there. We tried after doing Register process. We are getting a different error now.   HpToolsLauncher.exe -paramfile props26052017111301608.txt "Started..." Timeout is set to: 60 Run mode is set to: RUN_PLANNED_HOST ============================================================================ Starting test set execution Test set name: SmokeTestSuite, Test set id: 2551 Could not create scheduler, please verify ALM client installation on run machine by downloading and in installing the add-in form: http://higalmqcenter/qcbin//TDConnectivity_index.html   We tried installing  TDConnectivity_index.html  but not working.
          Hide
          xiwenhpe xiwen zhao added a comment -

          Hi,

          this is a duplicated issue (JENKINS-19374)

          We are not able to reproduce the problem locally, there is not much we can do at this stage.

          If you need to solve this issue please contact UFT support or ALM support to open a ticket, professional support team will follow up this issue. In this way your problem will have monitoring and tracking, in addition the case will be raised to higher level if it can not be solved in a short time. In another word it is guaranteed to be fixed by raising a support ticket.

          Meanwhile I will mark this issue as closed.

          Show
          xiwenhpe xiwen zhao added a comment - Hi, this is a duplicated issue ( JENKINS-19374 ) We are not able to reproduce the problem locally, there is not much we can do at this stage. If you need to solve this issue please contact UFT support or ALM support to open a ticket, professional support team will follow up this issue. In this way your problem will have monitoring and tracking, in addition the case will be raised to higher level if it can not be solved in a short time. In another word it is guaranteed to be fixed by raising a support ticket. Meanwhile I will mark this issue as closed.

            People

            • Assignee:
              evanchen Evan Chen
              Reporter:
              eldojoseph1234 Eldo Joseph
            • Votes:
              0 Vote for this issue
              Watchers:
              3 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: