Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-44324

Error while upgrading from 1.636 to 2.32.3

    Details

    • Similar Issues:

      Description

      while upgrading i am getting a NPE as per the https://groups.google.com/forum/#!topic/jenkinsci-users/Sae9nB6FZ-w

      i am filing a issue requesting for help. 

          <au.com.centrumsystems.hudson.plugin.buildpipeline.BuildPipelineView plugin="build-pipeline-plugin@1.3.3">

        Attachments

          Activity

          Hide
          dalvizu Dan Alvizu added a comment -

          Fixed in build-pipeline-plugin v1.5.7

          Show
          dalvizu Dan Alvizu added a comment - Fixed in build-pipeline-plugin v1.5.7
          Hide
          scm_issue_link SCM/JIRA link daemon added a comment -

          Code changed in jenkins
          User: Dan Alvizu
          Path:
          src/main/java/au/com/centrumsystems/hudson/plugin/buildpipeline/BuildPipelineView.java
          http://jenkins-ci.org/commit/build-pipeline-plugin/6fab1fdbd64b3251bc9970495b0501a27ef000b5
          Log:
          Merge pull request #110 from jenkinsci/JENKINS-44324

          [FIXED JENKINS-44324] fix readResolve() of build cards for ancient ve…

          Compare: https://github.com/jenkinsci/build-pipeline-plugin/compare/08939fa2c3bb...6fab1fdbd64b

          Show
          scm_issue_link SCM/JIRA link daemon added a comment - Code changed in jenkins User: Dan Alvizu Path: src/main/java/au/com/centrumsystems/hudson/plugin/buildpipeline/BuildPipelineView.java http://jenkins-ci.org/commit/build-pipeline-plugin/6fab1fdbd64b3251bc9970495b0501a27ef000b5 Log: Merge pull request #110 from jenkinsci/ JENKINS-44324 [FIXED JENKINS-44324] fix readResolve() of build cards for ancient ve… Compare: https://github.com/jenkinsci/build-pipeline-plugin/compare/08939fa2c3bb...6fab1fdbd64b
          Hide
          scm_issue_link SCM/JIRA link daemon added a comment -

          Code changed in jenkins
          User: Dan Alvizu
          Path:
          src/main/java/au/com/centrumsystems/hudson/plugin/buildpipeline/BuildPipelineView.java
          http://jenkins-ci.org/commit/build-pipeline-plugin/bfa47e5da3669ea58e4d8bbec1eed6095190c5b3
          Log:
          [FIXED JENKINS-44324] fix readResolve() of build cards for ancient versions of plugin

          Wrap hasPermission() in try catch so in the very worst case we don't
          brick Jenkins entirely

          Show
          scm_issue_link SCM/JIRA link daemon added a comment - Code changed in jenkins User: Dan Alvizu Path: src/main/java/au/com/centrumsystems/hudson/plugin/buildpipeline/BuildPipelineView.java http://jenkins-ci.org/commit/build-pipeline-plugin/bfa47e5da3669ea58e4d8bbec1eed6095190c5b3 Log: [FIXED JENKINS-44324] fix readResolve() of build cards for ancient versions of plugin Wrap hasPermission() in try catch so in the very worst case we don't brick Jenkins entirely
          Hide
          dalvizu Dan Alvizu added a comment -

          Cross-posting a comment from the mailing list:

           
          This is a bug in upgrading from a very old version of the plugin. As a work around you can remove that XML config and restart - this will delete your pipeline view, but you can re-create it.
           
          As an alternative, you can try upgrading to an older yet more recent version (such as 1.5.2), re-save the pipeline, and then upgrade to the very latest version. 

          Show
          dalvizu Dan Alvizu added a comment - Cross-posting a comment from the mailing list:   This is a bug in upgrading from a very old version of the plugin. As a work around you can remove that XML config and restart - this will delete your pipeline view, but you can re-create it.   As an alternative, you can try upgrading to an older yet more recent version (such as 1.5.2), re-save the pipeline, and then upgrade to the very latest version. 
          Hide
          rp0013 Raj P added a comment -

          i tried multiple upgrades (since i was in vcenter and had the luxury to do back and forth so i tried 2.32.3 my target then 2.46.2 as well as 2.61 the latest one ) 

          but my start point was 1.636 

           

          is there a location to find the disabled plugins other then the plugins directory ?

           

           

          i removed some of pinned plugins. but i am sure we did not have this plugin 

          no disabled plugin. actually at 1.636 i dont see this plugin anywehere

          rw-rr-. 1 jenkins jenkins        0 Mar 25  2014 ssh-slaves.jpi.pinned

          rw-rr-. 1 jenkins jenkins        0 Mar 25  2014 ldap.jpi.pinned

          rw-rr-. 1 jenkins jenkins        0 Nov 23  2015 credentials.jpi.pinned

          rw-rr-. 1 jenkins jenkins        0 Nov 23  2015 ssh-credentials.jpi.pinned

          rw-rr-. 1 jenkins jenkins        0 Nov 23  2015 mailer.jpi.pinned

          rw-rr-. 1 jenkins jenkins        0 Mar  8 09:10 maven-plugin.jpi.pinned

          rw-rr-. 1 jenkins jenkins        0 Mar  8 09:10 javadoc.jpi.pinned

          rw-rr-. 1 jenkins jenkins        0 Mar  8 09:10 junit.jpi.pinned

          Show
          rp0013 Raj P added a comment - i tried multiple upgrades (since i was in vcenter and had the luxury to do back and forth so i tried 2.32.3 my target then 2.46.2 as well as 2.61 the latest one )  but my start point was 1.636    is there a location to find the disabled plugins other then the plugins directory ?     i removed some of pinned plugins. but i am sure we did not have this plugin  no disabled plugin. actually at 1.636 i dont see this plugin anywehere rw-r r -. 1 jenkins jenkins        0 Mar 25  2014 ssh-slaves.jpi.pinned rw-r r -. 1 jenkins jenkins        0 Mar 25  2014 ldap.jpi.pinned rw-r r -. 1 jenkins jenkins        0 Nov 23  2015 credentials.jpi.pinned rw-r r -. 1 jenkins jenkins        0 Nov 23  2015 ssh-credentials.jpi.pinned rw-r r -. 1 jenkins jenkins        0 Nov 23  2015 mailer.jpi.pinned rw-r r -. 1 jenkins jenkins        0 Mar  8 09:10 maven-plugin.jpi.pinned rw-r r -. 1 jenkins jenkins        0 Mar  8 09:10 javadoc.jpi.pinned rw-r r -. 1 jenkins jenkins        0 Mar  8 09:10 junit.jpi.pinned
          Hide
          oleg_nenashev Oleg Nenashev added a comment -

          Please check the startup log. I'd guess you have a disabled/removed plugin implementing PipelineHeaderExtension

          Show
          oleg_nenashev Oleg Nenashev added a comment - Please check the startup log. I'd guess you have a disabled/removed plugin implementing PipelineHeaderExtension
          Hide
          oleg_nenashev Oleg Nenashev added a comment -

          The version is also 2.46.2 from what I see in the ML

          Show
          oleg_nenashev Oleg Nenashev added a comment - The version is also 2.46.2 from what I see in the ML
          Hide
          oleg_nenashev Oleg Nenashev added a comment - - edited

          {noformat}
          Caused by: java.lang.NullPointerException
          at au.com.centrumsystems.hudson.plugin.buildpipeline.ProjectForm.<init>(ProjectForm.java:136)
          at au.com.centrumsystems.hudson.plugin.buildpipeline.ProjectForm.<init>(ProjectForm.java:113)
          at au.com.centrumsystems.hudson.plugin.buildpipeline.ProjectForm.<init>(ProjectForm.java:113)
          at au.com.centrumsystems.hudson.plugin.buildpipeline.ProjectForm.<init>(ProjectForm.java:113)
          at au.com.centrumsystems.hudson.plugin.buildpipeline.ProjectForm.<init>(ProjectForm.java:90)
          at au.com.centrumsystems.hudson.plugin.buildpipeline.ProjectForm.as(ProjectForm.java:152)
          at au.com.centrumsystems.hudson.plugin.buildpipeline.DownstreamProjectGridBuilder$GridImpl.<init>(DownstreamProjectGridBuilder.java:80)
          at au.com.centrumsystems.hudson.plugin.buildpipeline.DownstreamProjectGridBuilder$GridImpl.<init>(DownstreamProjectGridBuilder.java:59)
          at au.com.centrumsystems.hudson.plugin.buildpipeline.DownstreamProjectGridBuilder.build(DownstreamProjectGridBuilder.java:230)
          at au.com.centrumsystems.hudson.plugin.buildpipeline.BuildPipelineView.isEmpty(BuildPipelineView.java:1021)
          at au.com.centrumsystems.hudson.plugin.buildpipeline.BuildPipelineView.hasPermission(BuildPipelineView.java:1002)
          at hudson.model.ViewGroupMixIn.getViews(ViewGroupMixIn.java:125)
          at jenkins.model.Jenkins.getViews(Jenkins.java:1837)

          {noformat}

          Show
          oleg_nenashev Oleg Nenashev added a comment - - edited {noformat} Caused by: java.lang.NullPointerException at au.com.centrumsystems.hudson.plugin.buildpipeline.ProjectForm.<init>(ProjectForm.java:136) at au.com.centrumsystems.hudson.plugin.buildpipeline.ProjectForm.<init>(ProjectForm.java:113) at au.com.centrumsystems.hudson.plugin.buildpipeline.ProjectForm.<init>(ProjectForm.java:113) at au.com.centrumsystems.hudson.plugin.buildpipeline.ProjectForm.<init>(ProjectForm.java:113) at au.com.centrumsystems.hudson.plugin.buildpipeline.ProjectForm.<init>(ProjectForm.java:90) at au.com.centrumsystems.hudson.plugin.buildpipeline.ProjectForm.as (ProjectForm.java:152) at au.com.centrumsystems.hudson.plugin.buildpipeline.DownstreamProjectGridBuilder$GridImpl.<init>(DownstreamProjectGridBuilder.java:80) at au.com.centrumsystems.hudson.plugin.buildpipeline.DownstreamProjectGridBuilder$GridImpl.<init>(DownstreamProjectGridBuilder.java:59) at au.com.centrumsystems.hudson.plugin.buildpipeline.DownstreamProjectGridBuilder.build(DownstreamProjectGridBuilder.java:230) at au.com.centrumsystems.hudson.plugin.buildpipeline.BuildPipelineView.isEmpty(BuildPipelineView.java:1021) at au.com.centrumsystems.hudson.plugin.buildpipeline.BuildPipelineView.hasPermission(BuildPipelineView.java:1002) at hudson.model.ViewGroupMixIn.getViews(ViewGroupMixIn.java:125) at jenkins.model.Jenkins.getViews(Jenkins.java:1837) {noformat}

            People

            • Assignee:
              dalvizu Dan Alvizu
              Reporter:
              rp0013 Raj P
            • Votes:
              0 Vote for this issue
              Watchers:
              4 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: