Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-44607

StackOverflowError with Declarative Pipeline

    Details

    • Similar Issues:

      Description

      After updating the plugin "Pipeline: Groovy" (ID:workflow-cps) from version 2.32 to 2.33 the jobs using declarative pipeline fail.

      A pipeline job configured with the following script (not from SCM):

      pipeline{
        agent any
        stages{
          stage('Step A'){
            steps{ 
              echo 'This is step A'
            }
          }
        }
      }

       

      fails and gives the following error:

      java.lang.StackOverflowError
      

       

      Complete output attached in this file: jenkinsOutput.txt

        Attachments

          Issue Links

            Activity

            albertosavila Alberto Sanchez created issue -
            albertosavila Alberto Sanchez made changes -
            Field Original Value New Value
            Summary StackOverflowError with Delcratative Pipeline StackOverflowError with Declarative Pipeline
            albertosavila Alberto Sanchez made changes -
            Environment Jenkins 2.46.3
            Plugin Pipeline: Groovy (workflow-cps)
            Jenkins 2.46.3
            Plugin Pipeline: Groovy (workflow-cps) version 2.33
            albertosavila Alberto Sanchez made changes -
            Description After updating the plugin "Pipeline: Groovy" (ID:workflow-cps) from version 2.32 to 2.33 the jobs using declarative pipeline fail.

            A pipeline job configured with the following script (not from SCM):
            {code:java}
            pipeline{
              agent any
              stages{
                stage('Step A'){
                  steps{
                    echo 'This is step A'
                  }
                }
              }
            }{code}
             

            fails and gives the following error:
            {code:java}
            java.lang.StackOverflowError
            {code}
             

            Complete output attached in this file: [^jenkinsOutput.txt]

             

             

             

             

             
            After updating the plugin "Pipeline: Groovy" (ID:workflow-cps) from version 2.32 to 2.33 the jobs using declarative pipeline fail.

            A pipeline job configured with the following script (not from SCM):
            {code:java}
            pipeline{
              agent any
              stages{
                stage('Step A'){
                  steps{
                    echo 'This is step A'
                  }
                }
              }
            }{code}
             

            fails and gives the following error:
            {code:java}
            java.lang.StackOverflowError
            {code}
             

            Complete output attached in this file: [^jenkinsOutput.txt]
            jglick Jesse Glick made changes -
            Link This issue duplicates JENKINS-44578 [ JENKINS-44578 ]
            jglick Jesse Glick made changes -
            Status Open [ 1 ] Resolved [ 5 ]
            Resolution Duplicate [ 3 ]

              People

              • Assignee:
                Unassigned
                Reporter:
                albertosavila Alberto Sanchez
              • Votes:
                1 Vote for this issue
                Watchers:
                3 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: