Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-44617

StackOverflowError after update

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Blocker
    • Resolution: Duplicate
    • Component/s: pipeline
    • Labels:
      None
    • Environment:
      Win2012R2
    • Similar Issues:

      Description

      Updated

      • Jenkins: 2.57 -> 2.63
      • Pipeline API: 2.13 -> 2.16
      • Pipeline: Groovy: 2.30 -> 2.33

      Jenkinsfile (reduced to reproduce)

      pipeline {
        agent any
        stages {
          stage ('Initialize') {
            steps {
              echo 'Placeholder.'
            }
          }
        }
      }
      

      according to the linter the file is ok.

      Build Output

      Seen 14 remote branches
      Obtained Jenkinsfile from b1e8a7081aea8404a24ea34b4eb3bd76a42f2de4
      [Pipeline] End of Pipeline
      java.lang.StackOverflowError
      	at org.codehaus.groovy.util.SingleKeyHashMap.get(SingleKeyHashMap.java:48)
      	at groovy.lang.MetaClassImpl$Index.getNullable(MetaClassImpl.java:3899)
      	at groovy.lang.MetaClassImpl.getMetaProperty(MetaClassImpl.java:2790)
      	at groovy.lang.MetaClassImpl.getMetaProperty(MetaClassImpl.java:2759)
      	at groovy.lang.MetaClassImpl.getProperty(MetaClassImpl.java:1780)
      	at groovy.lang.MetaClassImpl.getProperty(MetaClassImpl.java:3758)
      	at org.codehaus.groovy.runtime.InvokerHelper.getProperty(InvokerHelper.java:179)
      	at org.codehaus.groovy.runtime.callsite.PojoMetaClassGetPropertySite.callGetProperty(PojoMetaClassGetPropertySite.java:44)
      	at com.cloudbees.groovy.cps.CpsTransformer.loc(CpsTransformer.groovy:359)
      	at sun.reflect.GeneratedMethodAccessor147.invoke(Unknown Source)
      	at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
      	at java.lang.reflect.Method.invoke(Unknown Source)
      	at org.codehaus.groovy.reflection.CachedMethod.invoke(CachedMethod.java:93)
      	at groovy.lang.MetaMethod.doMethodInvoke(MetaMethod.java:325)
      	at org.codehaus.groovy.runtime.metaclass.ClosureMetaClass.invokeMethod(ClosureMetaClass.java:384)
      	at groovy.lang.MetaClassImpl.invokeMethod(MetaClassImpl.java:1022)
      	at org.codehaus.groovy.runtime.callsite.PogoMetaClassSite.callCurrent(PogoMetaClassSite.java:69)
      	at org.codehaus.groovy.runtime.callsite.AbstractCallSite.callCurrent(AbstractCallSite.java:166)
      	at com.cloudbees.groovy.cps.CpsTransformer$_visitPropertyExpression_closure34.doCall(CpsTransformer.groovy:732)
      	at com.cloudbees.groovy.cps.CpsTransformer$_visitPropertyExpression_closure34.doCall(CpsTransformer.groovy)
      	at sun.reflect.GeneratedMethodAccessor258.invoke(Unknown Source)
      	at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
      	at java.lang.reflect.Method.invoke(Unknown Source)
      	at org.codehaus.groovy.reflection.CachedMethod.invoke(CachedMethod.java:93)
      	at groovy.lang.MetaMethod.doMethodInvoke(MetaMethod.java:325)
      	at org.codehaus.groovy.runtime.metaclass.ClosureMetaClass.invokeMethod(ClosureMetaClass.java:294)
      	at groovy.lang.MetaClassImpl.invokeMethod(MetaClassImpl.java:1022)
      	at org.codehaus.groovy.runtime.callsite.PogoMetaClassSite.call(PogoMetaClassSite.java:42)
      	at org.codehaus.groovy.runtime.callsite.CallSiteArray.defaultCall(CallSiteArray.java:48)
      	at org.codehaus.groovy.runtime.callsite.PogoMetaClassSite.call(PogoMetaClassSite.java:57)
      	at org.codehaus.groovy.runtime.callsite.AbstractCallSite.call(AbstractCallSite.java:117)
      	at com.cloudbees.groovy.cps.CpsTransformer.makeChildren(CpsTransformer.groovy:344)
      	at sun.reflect.GeneratedMethodAccessor145.invoke(Unknown Source)
      	at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
      	at java.lang.reflect.Method.invoke(Unknown Source)
      	at org.codehaus.groovy.reflection.CachedMethod.invoke(CachedMethod.java:93)
      	at groovy.lang.MetaMethod.doMethodInvoke(MetaMethod.java:325)
      	at groovy.lang.MetaClassImpl.invokeMethod(MetaClassImpl.java:1213)
      	at groovy.lang.MetaClassImpl.invokeMethod(MetaClassImpl.java:1022)
      	at org.codehaus.groovy.runtime.callsite.PogoMetaClassSite.callCurrent(PogoMetaClassSite.java:69)
      	at org.codehaus.groovy.runtime.callsite.AbstractCallSite.callCurrent(AbstractCallSite.java:166)
      ...

       works again after Pipeline: Groovy downgrade

        Attachments

          Issue Links

            Activity

            jglick Jesse Glick added a comment -

            Duplicate of JENKINS-44578 I presume.

            bonuspunkt Robert Zach added a comment -

            that is correct


              People

              • Assignee:
                Unassigned
                Reporter:
                bonuspunkt Robert Zach
              • Votes:
                0 Vote for this issue
                Watchers:
                3 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: