Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-44657

Build history not copied after renaming the job's parent folder when using custom build directories

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Resolved (View Workflow)
    • Priority: Minor
    • Resolution: Fixed
    • Component/s: core
    • Labels:
      None
    • Environment:
      Jenkins 2.46.3; Mac OS X
    • Similar Issues:

      Description

      If you have configured Jenkins to use custom build directories and then rename a folder, the builds from any jobs in those folders are not correctly copied to the target folder.

      Steps to reproduce

      1. Configure Jenkins to use a custom build directory
      2. Create a folder
      3. In that folder, create a freestyle job
      3.1. Add a shell step with the text "artifact.txt"
      3.2. Add a post-build action to archive the artifacts
      4. Run the freestyle job
      5. See that the builds are showing up in the custom build directory
      6. Rename the folder
      7. Navigate to the job in the new folder
      8. Click on the build run earlier

      Actual Result

      The build logs and artifacts are missing from build #1 as seen in the screen shot after rename. Furthermore, if you restart Jenkins, the build history is completely lost.

      Expected Result

      The build logs and artifacts should not be lost. Restarting Jenkins should not result in the loss of build history.

        Attachments

          Issue Links

            Activity

            danielbeck Daniel Beck added a comment -

            Fixed towards 2.80.

            scm_issue_link SCM/JIRA link daemon added a comment -

            Code changed in jenkins
            User: Jesse Glick
            Path:
            core/src/main/java/hudson/Util.java
            http://jenkins-ci.org/commit/jenkins/6a4d800091926c5484483f79e8936ac9d21d67a1
            Log:
            JENKINS-44657 Noting when #2932 was merged.

            mhtouchette Marie-Helene Touchette added a comment - - edited

            Was this fix integrated in the latest LTS release (2.89.1)?

            Because I'm still losing projects' build histories when moving a subfolder containing projects from one folder to another.  And looking on disk, I can see that build folders/files were left behind at their old location.

            (my custom build record root directory: /jenkins/jobs/${ITEM_FULL_NAME}/builds)

             

            example: if I move SubFolder2 under Folder2, all builds for Project4 and Project5 are left behind (and lost, as far as the end-user is concerned)

             

            ROOT

             |

             |–Folder1 

             |      |— SubFolder1 : Project1, Project2, Project3 

             |      |--- SubFolder2 : Project4, Project5

             |

             |--Folder2

             |

            danielbeck Daniel Beck added a comment -

            Was this fix integrated in the latest LTS release (2.89.1)?

            As the two comments preceding yours will tell you, it's in 2.80, and therefore in 2.89, and therefore in 2.89.1.

            That said,

            I'm still losing projects' build histories when moving a subfolder containing projects from one folder to another.

            I wouldn't be surprised if this was missed as it's different from the reported issue. Pinging rsandell to see whether he expects this case to be handled by his fix, or whether that's a similar but different situation.

            hippostar Hippo Star added a comment - - edited

            We got 2.89.2 on Linux and renaming a job when using a custom build root directory still doesn't work.

            The job name changes but the actual folder is not renamed and we lose all build history and saved artifacts.

            If anyone needs to get their files back.... the files are still there inside the folder with the previous name so one option to get your stuff back is to re-rename your job back to the previous name.


              People

              • Assignee:
                rsandell rsandell
                Reporter:
                recampbell Ryan Campbell
              • Votes:
                0 Vote for this issue
                Watchers:
                6 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: