Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-44713

Failures to load bundle is not handled correctly

    Details

    • Similar Issues:

      Description

      It has been observed that if BlueOcean fails to load a bundle then no error is shown to the user and they are left with a white screen.

      This is a bad experience - at least a simple javascript.alert("Ooops, something went wrong") or something more advnaced should be shown to the user.  (Users should not have to go to their javascript console to work out that something is wrong).

       
      The case in point our VPN was having some transient DNS issues so that blueocean.js was loaded correctly but a message bundle was not.  No error was shown to the user.

      Other reasons for failed HTTP gets could be transient network issues, proxy denying the request for a reason (proxy restarting) etc etc...


       

       

       

        Attachments

          Issue Links

            Activity

            Hide
            jamesdumay James Dumay added a comment -

            James Nord duplicates JENKINS-40980. Ive added the tracking label to that ticket.

            Show
            jamesdumay James Dumay added a comment - James Nord duplicates JENKINS-40980 . Ive added the tracking label to that ticket.

              People

              • Assignee:
                Unassigned
                Reporter:
                teilo James Nord
              • Votes:
                0 Vote for this issue
                Watchers:
                2 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: