Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-44719

NPE with Matrix Combination 1.2.0

    Details

    • Type: Bug
    • Status: Resolved (View Workflow)
    • Priority: Critical
    • Resolution: Cannot Reproduce
    • Labels:
      None
    • Environment:
      Jenkins 2.46.3, CentOS 7, matrix-combinations-parameter 1.2.0, matrix-project 1.11
    • Similar Issues:

      Description

      If I select only one parameter, immediate crash. If I don't, it does canary build, then crashes.

      I rolled back to 1.1.0 and it works now, so definitely something new from 1.1.0 to 1.2.0.

      Triggering JOBNAME ยป PARAM_value1
      FATAL: null
      java.lang.NullPointerException
      	at java.util.HashSet.<init>(HashSet.java:118)
      	at hudson.model.ParametersAction.shouldSchedule(ParametersAction.java:228)
      	at hudson.model.Queue.scheduleInternal(Queue.java:615)
      	at hudson.model.Queue.schedule2(Queue.java:585)
      	at hudson.matrix.MatrixConfiguration.scheduleBuild(MatrixConfiguration.java:512)
      	at hudson.matrix.DefaultMatrixExecutionStrategyImpl.scheduleConfigurationBuild(DefaultMatrixExecutionStrategyImpl.java:247)
      	at hudson.matrix.DefaultMatrixExecutionStrategyImpl.run(DefaultMatrixExecutionStrategyImpl.java:159)
      	at hudson.matrix.MatrixBuild$MatrixBuildExecution.doRun(MatrixBuild.java:364)
      	at hudson.model.AbstractBuild$AbstractBuildExecution.run(AbstractBuild.java:534)
      	at hudson.model.Run.execute(Run.java:1728)
      	at hudson.matrix.MatrixBuild.run(MatrixBuild.java:313)
      	at hudson.model.ResourceController.execute(ResourceController.java:98)
      	at hudson.model.Executor.run(Executor.java:405)

        Attachments

          Issue Links

            Activity

            aarondmarasco_vsi Aaron D. Marasco added a comment -

            Yes, it's pre-SCM.

            aarondmarasco_vsi Aaron D. Marasco added a comment -

            Cannot lock a comment to a specific user and do not want to publicly post the full configuration. Emailed.

            ikedam ikedam added a comment -
            ikedam ikedam added a comment -

            Aaron D. Marasco

            Unfortunately, I could not reproduce the issue though I tried various combinations of configurations.
            I cannot do anything unless I can reproduce the issue my environment.
            And your configuration is too complicated to find the root cause.

            Please reopen the ticket if you find the least exact steps to reproduce the issue.

            aarondmarasco_vsi Aaron D. Marasco added a comment -

            Appreciate the time you put into it; thanks. I duped to JENKINS-44994 for the main matrix plugin with a specific link to your debugging work.


              People

              • Assignee:
                aarondmarasco_vsi Aaron D. Marasco
                Reporter:
                aarondmarasco_vsi Aaron D. Marasco
              • Votes:
                0 Vote for this issue
                Watchers:
                2 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: