Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Major
    • Resolution: Fixed
    • Component/s: performance-plugin
    • Labels:
      None
    • Environment:
      Performance Plugin 3.1
    • Similar Issues:

      Description

      In a pipeline, if you try to call perfReport relativeUnstableThresholdNegative: 1 you will get the following error:

      org.codehaus.groovy.control.MultipleCompilationErrorsException: startup failed:
      WorkflowScript: 129: Invalid parameter “relativeUnstableThresholdNegative”, did you mean “relativeUnstableThresholdPositive”?

      In addition (and probably related) you can't set{{relativeUnstableThresholdNegative}} via the snippet generator "Unstable % Range ".

      I think this may be fixed in https://github.com/jenkinsci/performance-plugin/pull/114 which was accepted after v3.1 was released.

        Attachments

          Issue Links

            Activity

            docwhat Christian Höltje created issue -
            undera Andrey Pokhilko made changes -
            Field Original Value New Value
            Status Open [ 1 ] Resolved [ 5 ]
            Resolution Fixed [ 1 ]
            docwhat Christian Höltje added a comment - - edited

            Andrey Pokhilko Is that a good idea? Using a snapshot?  I'm loathe to restart our Jenkins because it is big and busy...

            to be clear: I'm saying an official release would be worth doing a restart of Jenkins, but just a snapshot and then a short while later the official may not.  That being said, I have one user who is very vocal about this breakage (hi mstave!)

            undera Andrey Pokhilko added a comment -

            The snapshot has only that PR applied compared to latest release. I'm not planning release any soon, so using snapshot is good option. And it would help us understand if the fix is actually helps or not.

            docwhat Christian Höltje added a comment -

            Fair enough.  I'll see if I can find some quiet time.  I grabbed a copy so it won't go away when the workspace is rebuilt on the cloudbees jenkins.

            undera Andrey Pokhilko added a comment -

            I'm sorry, but I don't want disrupt everyone with new release just because of this single fix. Practice shows that some more issues can be revealed before we're making next official release.

            If there would be crowds of people saying this issue affects them - that would change its severity. But for now I have only you reporting this issue, so I apologize for the bug, but let's wait a bit with next release.

            The snapshot installation is no way different from "official" release in terms of work disruption. So if you're in hurry with this issue - just find some time window to roll it out.

            docwhat Christian Höltje added a comment - - edited

            It is rolled out on our system. mstave can report on if it is broken or not...

            mstave mstave added a comment -

            This problem was fixed by that change.   It surfaced a new problem, we hadn't been specifying sourceDataFiles, and it gave an error saying it was required.   I assume that's As Designed, so we set to what we thought was the auto-default 

            sourceDataFiles: '*/.jtl'

            and then all was well.

            docwhat Christian Höltje added a comment - - edited

            Sounds like a resounding success then, Andrey Pokhilko!  I'll close this then.

            artem_fedorov Artem Fedorov made changes -
            Link This issue is duplicated by JENKINS-45066 [ JENKINS-45066 ]
            artem_fedorov Artem Fedorov made changes -
            Assignee Andrey Pokhilko [ undera ] Artem Fedorov [ artem_fedorov ]
            artem_fedorov Artem Fedorov added a comment -
            artem_fedorov Artem Fedorov made changes -
            Status Resolved [ 5 ] Closed [ 6 ]

              People

              • Assignee:
                artem_fedorov Artem Fedorov
                Reporter:
                docwhat Christian Höltje
              • Votes:
                0 Vote for this issue
                Watchers:
                4 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: