Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-44791

Credentials for docker secured connection (TLS) not appliied

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Open (View Workflow)
    • Priority: Minor
    • Resolution: Unresolved
    • Labels:
      None
    • Environment:
      docker - on server and client 17.0.5
      jenkins - tried on 2.46.3 and 2.64
      docker-custom-build-environment-plugin - 1.65
      docker-common-plugin - 1.6
    • Similar Issues:

      Description

      Similar to https://issues.jenkins-ci.org/browse/JENKINS-33212

      Configured docker with tlsverify, specified docker url and credentials, but build fails:

      $ docker -H tcp://example.com:2376 exec --tty ef68c517b63f7c3b1e7755edab45d16ee124bac81aa0764a0685cf7462b0fd2b env
      Post http://drugc0de.net:2376/v1.29/containers/ef68c517b63f7c3b1e7755edab45d16ee124bac81aa0764a0685cf7462b0fd2b/exec: malformed HTTP response "\x15\x03\x01\x00\x02\x02\x16".
      * Are you trying to connect to a TLS-enabled daemon without TLS?

      Identical configs for docker build and publish works fine.

        Attachments

          Activity

          There are no comments yet on this issue.

            People

            • Assignee:
              jonhermansen Jon Hermansen
              Reporter:
              drugc0de Valeriy Polischuk
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated: