Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-44889

Blue Ocean 1.1.0+ release notes/changelog missing

    Details

    • Similar Issues:
    • Sprint:
      Blue Ocean 1.2-beta1, Blue Ocean 1.2-beta2, Blue Ocean 1.2-beta3

      Description

      As of a few days ago, the various Blue Ocean plugins are showing an available 1.1.0 release in my Manage Plugins page (using https://updates.jenkins-ci.org/stable/update-center.json as a source). However, none of the places I can think to check are showing any details for this:

      What happened?

      EDIT: I can see that 1.1.1 and 1.1.2 have been released, and 1.1.3 is pending, but none of them show release notes/change log. The two plugin pages (plugins.jenkins.io and wiki.jenkins-ci.org) just how "Loading" panels that never populate, as shown in Kamil Grabowski's screenshot.

       

        Attachments

          Issue Links

            Activity

            medianick Nick Jones created issue -
            medianick Nick Jones added a comment -

            The plugin manager now shows 1.1.1 as being available, but still none of the other pages I listed in the original report are showing information for it (aside from the existence of a `blueocean-parent-1.1.1` release at https://github.com/jenkinsci/blueocean-plugin/releases).

            jamesdumay James Dumay added a comment - - edited

            Apologies, I was flying over the pacific and hadn't published the release notes. They are always at https://wiki.jenkins-ci.org/display/JENKINS/Blue+Ocean+Plugin

            I am not sure why Github isn't producing a changelog for the diff. Its also worth noting we do not use Github for release notes/tracking.

            Thanks
            James

            jamesdumay James Dumay made changes -
            Field Original Value New Value
            Status Open [ 1 ] Resolved [ 5 ]
            Resolution Done [ 10000 ]
            jamesdumay James Dumay made changes -
            Status Resolved [ 5 ] Closed [ 6 ]
            y3ti Kamil Grabowski added a comment - - edited

            Release notes still are not available.

            EDIT: I have added the screenshot.

            y3ti Kamil Grabowski made changes -
            Resolution Done [ 10000 ]
            Status Closed [ 6 ] Reopened [ 4 ]
            y3ti Kamil Grabowski made changes -
            medianick Nick Jones added a comment -

            Thanks Kamil Grabowski; I see the same perpetually spinning panels under the 1.1.0 through 1.1.3 change log sections too, and an equivalent view at https://plugins.jenkins.io/blueocean

            medianick Nick Jones made changes -
            Summary Blue Ocean 1.1.0 release notes/changelog missing Blue Ocean 1.1.3 release notes/changelog missing
            medianick Nick Jones made changes -
            Description As of a few days ago, the various Blue Ocean plugins are showing an available 1.1.0 release in my Manage Plugins page (using [https://updates.jenkins-ci.org/stable/update-center.json] as a source). However, none of the places I can think to check are showing any details for this:
             * [https://plugins.jenkins.io/blueocean] (linked to from the plugin manager) lists 1.1.0 but says "JIRA project doesn't exist or you don't have permission to view it."
             * [https://wiki.jenkins-ci.org/display/JENKINS/Blue+Ocean+Plugin] shows the latest release as 1.0.1
             * [https://github.com/jenkinsci/blueocean-plugin/releases] shows a 1.1.0 release but no changelog
             * [https://github.com/jenkinsci/blueocean-plugin/compare/blueocean-1.0.1...blueocean-1.1.0] says "There isn't anything to compare"

            What happened?
            As of a few days ago, the various Blue Ocean plugins are showing an available 1.1.0 release in my Manage Plugins page (using [https://updates.jenkins-ci.org/stable/update-center.json] as a source). However, none of the places I can think to check are showing any details for this:
             * [https://plugins.jenkins.io/blueocean] (linked to from the plugin manager) lists 1.1.0 but says "JIRA project doesn't exist or you don't have permission to view it."
             * [https://wiki.jenkins-ci.org/display/JENKINS/Blue+Ocean+Plugin] shows the latest release as 1.0.1
             * [https://github.com/jenkinsci/blueocean-plugin/releases] shows a 1.1.0 release but no changelog
             * [https://github.com/jenkinsci/blueocean-plugin/compare/blueocean-1.0.1...blueocean-1.1.0] says "There isn't anything to compare"

            What happened?

            EDIT: I can see that 1.1.1 and 1.1.2 have been released, and 1.1.3 is pending, but none of them show release notes/change log. The two plugin pages (plugins.jenkins.io and wiki.jenkins-ci.org) just how "Loading" panels that never populate, as shown in [~y3ti]'s screenshot.

             
            medianick Nick Jones made changes -
            Summary Blue Ocean 1.1.3 release notes/changelog missing Blue Ocean 1.1.0+ release notes/changelog missing
            jamesdumay James Dumay made changes -
            Attachment releasenotes.png [ 38536 ]
            jamesdumay James Dumay added a comment - - edited

            Kamil Grabowski Nick Jones no spinning of death here but I can confirm its not visible on https://plugins.jenkins.io/blueocean

            Can you try doing a hard refresh on the wiki page?

            jamesdumay James Dumay added a comment -

            Thorsten Scherler gus reiber any idea why the plugin site wouldn't be getting the dynamic content? Is it fixable?

            jamesdumay James Dumay made changes -
            Assignee James Dumay [ jamesdumay ]
            jamesdumay James Dumay made changes -
            Sprint Blue Ocean 1.2-beta1 [ 336 ]
            jamesdumay James Dumay made changes -
            Rank Ranked lower
            michaelneale Michael Neale added a comment -

            JIRA seems to be playing silly bugger. 

            Github seems to be not smart enough to compare tags... here is the link with the commit hashes for the releases: https://github.com/jenkinsci/blueocean-plugin/compare/9b77619...2c3ae50 that can help for now until the JIRA/conflience issue is resolved. It did slow up the other day... 

            y3ti Kamil Grabowski added a comment -

            James Dumay: I had cleared the browser cache but it didn't help. I tried on safari, firefox and chrome on MacOS.

            jamesdumay James Dumay added a comment -

            Kamil Grabowski what happens if you logout of JIRA and refresh the page?

            y3ti Kamil Grabowski added a comment -

            The same

            tscherler Thorsten Scherler added a comment -

            James Dumay not sure, but I left plugin site when started on BO, I have no clue about current stand, sorry.

            medianick Nick Jones made changes -
            Attachment image-2017-06-20-09-07-40-092.png [ 38538 ]
            medianick Nick Jones added a comment -

            James Dumay, hard refresh didn't help. Wiki looks the same as in Kamil's screenshot. I've also tried logging out of JIRA and reloading both while logged out, then logging back in and refreshing again. Plugins site looks like this:

            michaelneale Michael Neale added a comment -

            yes it still isn't loading for me - it seems to be at the JIRA end. The release notes in the past were hand editor - now they are based on JIRA queries - but that seems to not be working. 

            jamesdumay James Dumay made changes -
            Sprint Blue Ocean 1.2-beta1 [ 336 ] Blue Ocean 1.2-beta1, Blue Ocean 1.2-beta2 [ 336, 341 ]
            medianick Nick Jones made changes -
            Attachment image-2017-06-27-09-28-35-444.png [ 38661 ]
            medianick Nick Jones added a comment -

            I noticed this on the wiki page:

            So, perhaps it's a JIRA Application Link configuration issue, e.g., one of the incoming authentication fields is set incorrectly?

            danielbeck Daniel Beck added a comment -

            James Dumay

            any idea why the plugin site wouldn't be getting the dynamic content? Is it fixable?

            The plugin site basically scrapes the wiki. Be too clever with macros like this and it just won't work.

            danielbeck Daniel Beck added a comment -

            Any problems related to the wiki page are likely caused by caching. E.g. it didn't work for me at first, but it works on https://wiki.jenkins.io/display/JENKINS/Blue+Ocean+Plugin?foo  (which circumvents the static cache), so might be related to that.

            Unfortunately we don't have the resources to run uncached Confluence.

            michaelneale Michael Neale added a comment -

            Daniel Beck James Dumay ah - cache busting does it. So I made a small change and it now shows up - I think this may be ok (not sure if the scraping will work though - maybe on next scrape). 

             

            I think can close this then. 

            michaelneale Michael Neale made changes -
            Status Reopened [ 4 ] Open [ 1 ]
            michaelneale Michael Neale added a comment -

            was a bad cache

            michaelneale Michael Neale made changes -
            Status Open [ 1 ] Resolved [ 5 ]
            Resolution Fixed [ 1 ]
            jamesdumay James Dumay added a comment -

            I don't have time right now to go through the list of issues and copy/paste them to make the Plugin Site work. Ideally the plugin site would work - confluence has dynamic content.

            danielbeck Daniel Beck added a comment -

            confluence has dynamic content

            Technically true, but in ~9 months it hasn't come up in other content important enough for anyone to complain.

            medianick Nick Jones made changes -
            Attachment image-2017-06-30-09-27-45-140.png [ 38697 ]
            medianick Nick Jones added a comment -

            The "?foo" workaround does work for the wiki page specifically – I can now get to the release notes with some minor effort – but I don't consider this issue resolved/closed as reported. Neither https://plugins.jenkins.io/blueocean nor https://wiki.jenkins.io/display/JENKINS/Blue+Ocean+Plugin are displaying the release notes for 1.1.0 onward, under their default behavior. The wiki now looks like this:

            And the plugins page remains the same as before. 

            michaelneale Michael Neale made changes -
            Resolution Fixed [ 1 ]
            Status Resolved [ 5 ] Reopened [ 4 ]
            michaelneale Michael Neale added a comment - - edited

            right Nick Jones I am seeing it again - I guess we will have to hand edit the change log somehow... 

            michaelneale Michael Neale made changes -
            Assignee James Dumay [ jamesdumay ] Michael Neale [ michaelneale ]
            michaelneale Michael Neale made changes -
            Status Reopened [ 4 ] In Progress [ 3 ]
            michaelneale Michael Neale made changes -
            Status In Progress [ 3 ] In Review [ 10005 ]
            michaelneale Michael Neale added a comment -

            hey Nick Jones is this any better for you now? I am trying another way to do it. It shows up for me now - but it is hard to tell for others (confluence sometimes tries to be too clever for its own good, once it knows they are JIRA links). Any chance you can confirm? 

            danielbeck Daniel Beck added a comment -

            Filed WEBSITE-374 for what appears to be the problem on the plugins site now.

            Really I should just change the plugin info macro to just add a link to the plugins site and be done

            michaelneale Michael Neale added a comment -

            Daniel Beck is the content a bit better now? It shouldn't be a macro but content that is pasted in - but confluence does try to be clever... 

            danielbeck Daniel Beck added a comment - - edited

            Michael Neale I expect this will help since it can be {{curl}}ed, except WEBSITE-374 negates your improvement for now on the plugin site.

            medianick Nick Jones added a comment -

            Michael Neale, yes, the wiki content looks correct, while the plugins page has empty sections (as reported in WEBSITE-374).

            tsutsarin_fuib Nikolay Tsutsarin made changes -
            Link This issue is related to INFRA-1265 [ INFRA-1265 ]
            jamesdumay James Dumay made changes -
            Sprint Blue Ocean 1.2-beta1, Blue Ocean 1.2-beta2 [ 336, 341 ] Blue Ocean 1.2-beta1, Blue Ocean 1.2-beta2, Blue Ocean 1.2-beta3 [ 336, 341, 346 ]
            michaelneale Michael Neale added a comment -

            should be better now - may take a lttle while for the jenkins.io website to reflect it... (The wiki page is correct, however)

            michaelneale Michael Neale made changes -
            Status In Review [ 10005 ] Closed [ 6 ]
            Resolution Fixed [ 1 ]

              People

              • Assignee:
                michaelneale Michael Neale
                Reporter:
                medianick Nick Jones
              • Votes:
                2 Vote for this issue
                Watchers:
                6 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: