Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-44973

Remoting tests crash when running on Socket or STDOUT/STDERR without Workspace

    Details

    • Type: Bug
    • Status: Resolved (View Workflow)
    • Priority: Blocker
    • Resolution: Fixed
    • Component/s: remoting
    • Labels:
      None
    • Similar Issues:

      Description

      Discovered it during testing the recent remoting version on SSH. Likely some Unit tests are also unstable due to it.

       

      Exception in thread "main" java.lang.IllegalArgumentException

      at hudson.remoting.FileSystemJarCache.<init>(FileSystemJarCache.java:52)

      at hudson.remoting.Launcher.runWithStdinStdout(Launcher.java:679)

      at hudson.remoting.Launcher.run(Launcher.java:361)

      at hudson.remoting.Launcher.main(Launcher.java:276)

       

       

        Attachments

          Issue Links

            Activity

            scm_issue_link SCM/JIRA link daemon added a comment -

            Code changed in jenkins
            User: Oleg Nenashev
            Path:
            src/main/java/hudson/remoting/Channel.java
            src/main/java/hudson/remoting/ChannelBuilder.java
            src/main/java/hudson/remoting/Engine.java
            src/main/java/hudson/remoting/FileSystemJarCache.java
            src/main/java/hudson/remoting/JarCache.java
            src/main/java/hudson/remoting/Launcher.java
            src/test/java/hudson/remoting/EngineTest.java
            http://jenkins-ci.org/commit/remoting/589275ea8d2198f86aa9fc78e68b024446c6124b
            Log:
            JENKINS-44973 - Ensure that JAR Cache management works correctly in Launcher

            It is an unreleased regression caused by me in https://github.com/jenkinsci/remoting/pull/166

            Discovered it during testing the recent remoting version on SSH. Likely some Unit tests are also unstable due to it.

            scm_issue_link SCM/JIRA link daemon added a comment -

            Code changed in jenkins
            User: Oleg Nenashev
            Path:
            src/main/java/hudson/remoting/Channel.java
            src/main/java/hudson/remoting/ChannelBuilder.java
            src/main/java/hudson/remoting/Engine.java
            src/main/java/hudson/remoting/FileSystemJarCache.java
            src/main/java/hudson/remoting/JarCache.java
            src/main/java/hudson/remoting/Launcher.java
            src/test/java/hudson/remoting/EngineTest.java
            http://jenkins-ci.org/commit/remoting/35065e7ef4fe6c2dd3f4b99998d9f041830c57f4
            Log:
            Merge pull request #167 from oleg-nenashev/bug/JENKINS-44973

            JENKINS-44973 - Ensure that JAR Cache management works correctly in Launcher

            Compare: https://github.com/jenkinsci/remoting/compare/638dbdeed903...35065e7ef4fe

            oleg_nenashev Oleg Nenashev added a comment -

            No need in the changelogging, it is effectively a part of the JENKINS-18578  fix in 3.10


              People

              • Assignee:
                oleg_nenashev Oleg Nenashev
                Reporter:
                oleg_nenashev Oleg Nenashev
              • Votes:
                0 Vote for this issue
                Watchers:
                2 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: