Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-45009

Active Directory Plugin 2.5 incorrectly reports bad domain

    Details

    • Similar Issues:

      Description

      After updating to the active directory plugin version 2.5 it has started to report my domain as invalid.  I get the error text '<domain> doesn't look like a valid domain name' when clicking the Test Domain button on the Global Security settings page.

      I think this is not working due to this commit and line linked in the commit https://github.com/jenkinsci/active-directory-plugin/commit/4e46466#diff-89b7b6ee37e6be852370249c03e7ca8cR283.  It's checking for not null and reporting an error when it should do the opposite, at least from my read of the changed code.

      If I visit the new Active Directory Health Status management page, it reports the following information:
      DNS resolution : Domain was correctly resolved to NS/A record
      Global Catalog : Global Catalog not exposed
      Ldap Catalog : Ldap Catalog correctly exposed

        Attachments

          Issue Links

            Activity

            Hide
            fbelzunc Félix Belzunce Arcos added a comment - - edited

            Argggghhh you are right Peter Nordquist - I will fix this tomorrow.

            Next step of for the AD plugin is to increase the number of tests (maven and integration) in order to avoid these kinds of problems to happen.

            Show
            fbelzunc Félix Belzunce Arcos added a comment - - edited Argggghhh you are right Peter Nordquist - I will fix this tomorrow. Next step of for the AD plugin is to increase the number of tests (maven and integration) in order to avoid these kinds of problems to happen.
            Hide
            scm_issue_link SCM/JIRA link daemon added a comment -

            Code changed in jenkins
            User: Félix Belzunce Arcos
            Path:
            src/main/java/hudson/plugins/active_directory/ActiveDirectoryDomain.java
            http://jenkins-ci.org/commit/active-directory-plugin/99e0968bbe91ee584326fb683323bc45b892cfff
            Log:
            JENKINS-45009 If getRecordFromDomain returns null report the problem

            Show
            scm_issue_link SCM/JIRA link daemon added a comment - Code changed in jenkins User: Félix Belzunce Arcos Path: src/main/java/hudson/plugins/active_directory/ActiveDirectoryDomain.java http://jenkins-ci.org/commit/active-directory-plugin/99e0968bbe91ee584326fb683323bc45b892cfff Log: JENKINS-45009 If getRecordFromDomain returns null report the problem
            Hide
            scm_issue_link SCM/JIRA link daemon added a comment -

            Code changed in jenkins
            User: Felix Belzunce Arcos
            Path:
            src/main/java/hudson/plugins/active_directory/ActiveDirectoryDomain.java
            http://jenkins-ci.org/commit/active-directory-plugin/cb19db0a06984601385240813a3928ef5745417f
            Log:
            Merge pull request #73 from fbelzunc/JENKINS-45009

            JENKINS-45009 If getRecordFromDomain returns null report the problem

            Compare: https://github.com/jenkinsci/active-directory-plugin/compare/c525f6cc72eb...cb19db0a0698

            Show
            scm_issue_link SCM/JIRA link daemon added a comment - Code changed in jenkins User: Felix Belzunce Arcos Path: src/main/java/hudson/plugins/active_directory/ActiveDirectoryDomain.java http://jenkins-ci.org/commit/active-directory-plugin/cb19db0a06984601385240813a3928ef5745417f Log: Merge pull request #73 from fbelzunc/ JENKINS-45009 JENKINS-45009 If getRecordFromDomain returns null report the problem Compare: https://github.com/jenkinsci/active-directory-plugin/compare/c525f6cc72eb...cb19db0a0698
            Hide
            peter_nordquist Peter Nordquist added a comment -

            Version 2.6 fixed this, thanks!

            Show
            peter_nordquist Peter Nordquist added a comment - Version 2.6 fixed this, thanks!
            Hide
            sluen001 Steven Luengo added a comment -

            Félix Belzunce Arcos,

             

            I am also having a similar issue, but I am on version 2.6 of the AD plugin. This was working before.

             

            Show
            sluen001 Steven Luengo added a comment - Félix Belzunce Arcos ,   I am also having a similar issue, but I am on version 2.6 of the AD plugin. This was working before.  

              People

              • Assignee:
                fbelzunc Félix Belzunce Arcos
                Reporter:
                peter_nordquist Peter Nordquist
              • Votes:
                0 Vote for this issue
                Watchers:
                4 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: