Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-45105

Sending data to influxdb fails due exception

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Major
    • Resolution: Won't Fix
    • Component/s: influxdb-plugin
    • Labels:
      None
    • Environment:
      Jenkins v 2.66
      Performance plugin 3.1
      Influxdb plugin 1.12.2
    • Similar Issues:

      Description

      Sending data to influxdb fails. Log code:

      Could not report to InfluxDB. Ignoring Exception.
      java.lang.RuntimeException: {"error":"field type conflict: input field \"build_result_ordinal\" on measurement \"jenkins_data\" is type int64, already exists as type float"}
      
      	at org.influxdb.impl.InfluxDBImpl.execute(InfluxDBImpl.java:387)
      	at org.influxdb.impl.InfluxDBImpl.write(InfluxDBImpl.java:247)
      	at jenkinsci.plugins.influxdb.InfluxDbPublisher.writeToInflux(InfluxDbPublisher.java:280)
      	at jenkinsci.plugins.influxdb.InfluxDbPublisher.perform(InfluxDbPublisher.java:256)
      	at hudson.tasks.BuildStepCompatibilityLayer.perform(BuildStepCompatibilityLayer.java:81)
      	at hudson.tasks.BuildStepMonitor$1.perform(BuildStepMonitor.java:20)
      	at hudson.model.AbstractBuild$AbstractBuildExecution.perform(AbstractBuild.java:730)
      	at hudson.model.AbstractBuild$AbstractBuildExecution.performAllBuildSteps(AbstractBuild.java:676)
      	at hudson.model.Build$BuildExecution.cleanUp(Build.java:196)
      	at hudson.model.Run.execute(Run.java:1782)
      	at hudson.model.FreeStyleBuild.run(FreeStyleBuild.java:43)
      	at hudson.model.ResourceController.execute(ResourceController.java:97)
      	at hudson.model.Executor.run(Executor.java:415)
      

      Do we have to configure something?

      Sorry - but we have to rollback to 1.11 which was the latest version working - that means a rollback of the performance-plugin too

        Attachments

          Issue Links

            Activity

            aleksisimell Aleksi Simell added a comment -

            This is a known issue (see https://issues.jenkins-ci.org/browse/JENKINS-43539 comments) and I'm working on a fix for this.

            zioschild Sven Appenrodt added a comment -

            Found it. Sorry for the double but the linked tickets has not an "open" state and is therefore not in the list of konwn issues.

            aleksisimell Aleksi Simell added a comment -

            Finally found the root cause for this. Previously I had used a deprecated version of Influx-java function `field`. It takes 2 parameters typed String and Object and typecasts the Object into an Integer, Short, BigInteger, Long, or Byte and takes `doubleValue()` from these. This was changed in version 1.12 to use the more recent `addField` function, which no longer takes the `doubleValue()` and returns the value as it is.

            Basically, this means I would either have to return data generation to use the deprecated `field`function, which I wouldn't really like to do or have people drop their data history and start anew, which I'm also not a fan, but feels like the only correct way.

            aleksisimell Aleksi Simell added a comment -

            This is caused from the use of a deprecated function in influx-java. The updated function calls the up-to-date function, but causes errors if data has been sent with the old influx-java error.


              People

              • Assignee:
                aleksisimell Aleksi Simell
                Reporter:
                zioschild Sven Appenrodt
              • Votes:
                0 Vote for this issue
                Watchers:
                2 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: