Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-45177

Dependency error with ruby-runtime while installing Cucumber plugin blocks execution of cucumber tests

    Details

    • Similar Issues:

      Description

      Environment: Live
      System: Windows 7 & Windows 10 - 64 bit
      Browser: IE & Chrome
      Version: Jenkins: 2.60.1 ; Cucumber Plugin: v0.0.2 ; ruby-runtime Plugin:v0.12

      Test Steps:

      • Install the latest version of Jenkins
      • Install all the suggested plugins by Jenkins
      • Once Jenkins is ready navigate to Manage Jenkins -> Manage Plugins -> click on available plugins -> Search for cucumber plugin
      • Install Cucumber plugin which comes along with the ruby-runtime dependency
      • Restart Jenkins after download is complete

      Expected Behavior: Cucumber plugin is installed successfully along with the ruby-runtime dependency

      Actual Behavior: We get an error on Jenkins saying - There are dependency errors loading some plugins: •Cucumber Plugin v0.0.2 ◦ruby-runtime v0.10 is missing. To fix, install v0.10 or later.

      We have tried installing both the plugins through plugins manager & also through manual upload multiple times but we still get the dependency error. When we check in the Jenkins plugins folder on windows then we can see both the plugins there but it is somehow not shown in the installed plugins section on the plugin manager. This is blocking us from running cucumber tests. We have tried re-installing Jenkins & the plugins multiple times but we get the same dependency error.

        Attachments

          Activity

          Hide
          agelop Aldo Lopes added a comment -

          I'm having this exact same issue. Is there any update?

          Show
          agelop Aldo Lopes added a comment - I'm having this exact same issue. Is there any update?
          Hide
          jzajac2 john zajac added a comment -

          yah this is a dealbreaker for me as I'd like to use the travis community plugin (as well as Cucumber one noted here)

          Show
          jzajac2 john zajac added a comment - yah this is a dealbreaker for me as I'd like to use the travis community plugin (as well as Cucumber one noted here)
          Show
          fleslife Fajar Lesmana added a comment - https://stackoverflow.com/questions/44403642/jenkins-plugin-installation-failing

            People

            • Assignee:
              Unassigned
              Reporter:
              ishan_soni Ishan Soni
            • Votes:
              3 Vote for this issue
              Watchers:
              4 Start watching this issue

              Dates

              • Created:
                Updated: