Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-45200

Archiving artifacts fails, but build step is shown with a green dot

    Details

    • Similar Issues:

      Description

      I use the archiveArtifact step in my Jenkinsfile, and even though it failed with the below messages in the console, the "Pipeline Steps" view showed a green ball for the archive artifact step, which made the error very hard to track down.

      [Pipeline] [ios] stage
      [Pipeline] [ios] { (Archive artifacts iOS64)
      [Pipeline] [ios] step
      16:10:28 [ios] Archiving artifacts
      16:10:28 [ios] ERROR: No artifacts found that match the file pattern "build/CVIE*". Configuration error?
      16:10:28 [ios] ERROR: ‘build/CVIE*’ doesn’t match anything because it is treated case sensitively. You can deactivate case sensitivity to get matches
      16:10:28 [ios] [Pipeline] [ios] }
      [Pipeline] [ios] // stage
      [Pipeline] [ios] }

        Attachments

          Issue Links

            Activity

            bitwiseman Liam Newman added a comment -

            Andrew Bayer Jesse Glick 

            This was resolved as duplicate of JENKINS-38005, but it seems quite different.

            Andrew this is the issue I asking you about earlier today.

            I've updated the info on this bug - Jenkins 2.73.2.1, Pipeline: Basic Steps 2.6.  

            I run the Jenkinsfile below:

             

            pipeline {
              agent any
              stages {
                stage('Buzz Build') {
                  steps {
                    archiveArtifacts(artifacts: 'target/*.jar', fingerprint: true) 
                    sh "echo You shouldn't see me!"
                  }
                }
              }
            }
            

             

             

            And I get this log output:

             

            Pipeline] // stage
            [Pipeline] withEnv
            [Pipeline] {
            [Pipeline] stage
            [Pipeline] { (Buzz Build)
            [Pipeline] archiveArtifacts
            Archiving artifacts
            ERROR: No artifacts found that match the file pattern "target/*.jar". Configuration error?
            ERROR: ‘target/*.jar’ doesn’t match anything: even ‘target’ doesn’t exist
            [Pipeline] sh
            [ine-intro-demo_archive-test-BOJHA5PE46R56247HSVQBPNFA4Q7BTKJS3UOCQCHQTQE56HTWMMA] Running shell script
            + echo You should not see me!
            You should not see me!
            [Pipeline] }
            [Pipeline] // stage
            [Pipeline] }
            [Pipeline] // withEnv
            [Pipeline] }
            [Pipeline] // node
            [Pipeline] End of Pipeline
            Finished: FAILURE
            

             

             

             

            batmat Baptiste Mathus added a comment -

            Just hit this too in Essentials. This is really unsettling and I fear can drive users crazy:

            • The whole Blue Ocean pipeline rendering is blue
            • Everything shows as blue in the Pipeline steps
              Despite all this, this still fails, and one has to look for the cause in many places.
            jglick Jesse Glick added a comment -

            Sounds like a dupe.


              People

              • Assignee:
                Unassigned
                Reporter:
                estyrke Emil Styrke
              • Votes:
                2 Vote for this issue
                Watchers:
                6 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: