Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-45202

Regenerating job definition via job dsl clears state

    XMLWordPrintable

    Details

    • Type: New Feature
    • Status: Closed (View Workflow)
    • Priority: Major
    • Resolution: Cannot Reproduce
    • Component/s: job-dsl-plugin
    • Labels:
      None
    • Environment:
      Plugin v1.9
      Jenkins v2.46
    • Similar Issues:

      Description

      When ever we make a change to our git repo which contains all the job DSL definitions, and push, all the jobs get re-created, and then on the next run of our job which uses the parallel test executor plugin, instead of running the usual 4 executors job, it only run 1 - as if it loses the state it had regarding the duration of each test.
      Since we generate it quite often it quite ruins the effect of using the parallel test executor plugin.

        Attachments

          Activity

          asafm Asaf M created issue -
          jglick Jesse Glick made changes -
          Field Original Value New Value
          Component/s job-dsl-plugin [ 16720 ]
          Component/s parallel-test-executor-plugin [ 17650 ]
          daspilker Daniel Spilker added a comment -

          Post a Job DSL script that reproduces the problem.

          daspilker Daniel Spilker made changes -
          Status Open [ 1 ] Resolved [ 5 ]
          Resolution Cannot Reproduce [ 5 ]
          daspilker Daniel Spilker made changes -
          Status Resolved [ 5 ] Closed [ 6 ]

            People

            • Assignee:
              Unassigned
              Reporter:
              asafm Asaf M
            • Votes:
              0 Vote for this issue
              Watchers:
              3 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: