Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-45287

Debian packaging should not be satisfied by Java 9

    Details

    • Similar Issues:

      Description

      The Debian package is the only one that still declares a Java dependency (https://github.com/jenkinsci/packaging/commit/188ffd36c2abd83ca9e572b6b1fb6d2f423685bc) but it declares ≥8.

      This can in some cases result in Java 9 installations when those appear to not work with Jenkins.

      If possible the dependency should be limited to exactly Java 8, or dropped altogether with corresponding explanation on the package listing page.

      Similarly, Java dependency documentation for Opensuse/Redhat should be reviewed to ensure we don't claim Java 9 compatibility.

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                rarabaolaza Raul Arabaolaza
                Reporter:
                danielbeck Daniel Beck
              • Votes:
                0 Vote for this issue
                Watchers:
                4 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: