Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-45419

'Use Repository' setting does not find other remote urls if multiple repos are added to job

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Resolved (View Workflow)
    • Priority: Major
    • Resolution: Fixed
    • Component/s: git-parameter-plugin
    • Labels:
      None
    • Environment:
      ubuntu 14.04
      java version "1.8.0_131"
      jenkins 2.60.1
      git-parameter-plugin 0.8.0
    • Similar Issues:

      Description

      If I add 2 git repositories to my job, and then add two git parameter instances (to list the branches from each repo) and set the 'Use Repository' setting to regex to identify each repo, only the first repo is resolved. The 2nd repo shows the 'No git repository is configured in the scm' error.

      I am not using the multi scm plugin, I just added two repos to the job.

      This had been working before I upgraded to the latest version, I think because I had named the two remotes, and then each git parameter instance was filtered to show only the branches from the specific remote.

        Attachments

          Activity

            People

            • Assignee:
              klimas7 Boguslaw Klimas
              Reporter:
              matty666 Matt Evans
            • Votes:
              0 Vote for this issue
              Watchers:
              8 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: