Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-45433

NullPointerException in startup trigger

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Major
    • Resolution: Cannot Reproduce
    • Component/s: startup-trigger-plugin
    • Environment:
    • Similar Issues:

      Description

      When trying to start a job manually, the job starts and then immediately the NullPointerException occurrs.

       

       
      FATAL: null
      java.lang.NullPointerException
      at org.jvnet.hudson.plugins.triggers.startup.HudsonStartupCause.getShortDescription(HudsonStartupCause.java:38)
      at hudson.model.Cause.print(Cause.java:121)
      at hudson.model.StreamBuildListener.started(StreamBuildListener.java:75)
      at hudson.model.Run.execute(Run.java:1720)
      at hudson.model.FreeStyleBuild.run(FreeStyleBuild.java:43)
      at hudson.model.ResourceController.execute(ResourceController.java:97)
      at hudson.model.Executor.run(Executor.java:405)
      Checking console output
      No emails were triggered.
      Finished: FAILURE
       

        Attachments

          Activity

          ejpenney Emory Penney added a comment -

          I'm unable to reproduce this issue on my setup.  Can you provide more details about what you're doing?  Would it be possible to see the job configuration?  Are you just clicking "Build with Parameters" then getting the NPE?  StartupTrigger shouldn't be involved with manual job execution at all, so something fishy is going on here.

          ejpenney Emory Penney added a comment -

          No feedback for 2 years, cannot reproduce. Assuming issue was a fluke.


            People

            • Assignee:
              ejpenney Emory Penney
              Reporter:
              tcb_xy Tim-Christian Bloss
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: