Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-45568

HTTP ERROR 404 Problem accessing /jenkins/job/myproject/build. Reason: Not Found

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Minor
    • Resolution: Not A Defect
    • Component/s: core
    • Labels:
    • Environment:
      Jenkins ver. 2.32.2
      centos 6.5
    • Similar Issues:

      Description

      The problem I met was: I tried to trigger jenkins project by api, but it failed:

      Api: curl -X POST 'http://localhost:8080/jenkins/job/bis-dx/build' --user '**:***' -H "$CRUMB"

      Failed info: 

      <p>Problem accessing /jenkins/job/bis-dx/build. Reason:
      <pre> Not Found</pre></p><hr><i><small>Powered by Jetty://</small></i><hr/>

       

      What I want to consult are:

      1. The api is correct or not? 
      2. If api is correct, whether the issue is the bug of the jenkins version I am using? If so, which version is better, how about 2.60.1? 

      Thanks

        Attachments

          Activity

          danielbeck Daniel Beck added a comment -

          Probably the wrong URL for a build that expects parameters. How to trigger builds is documented on /jenkins/job/bis-dx/api/ section "Perform a build"; guides on the web (notably also the Jenkins wiki) are often not great.

          So far this looks more like a support request that a bug report; those are better posted to #jenkins on Freenode, or to the jenkinsci-users mailing list.

          melissa Lee Melissa added a comment -

          Thanks a lot for the clue you gave me, I've found the correct URL.


            People

            • Assignee:
              Unassigned
              Reporter:
              melissa Lee Melissa
            • Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: