Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-45800

Step 'Recording NUnit tests results' because of java.lang.InterruptedException

    Details

    • Type: Bug
    • Status: Resolved (View Workflow)
    • Priority: Major
    • Resolution: Cannot Reproduce
    • Component/s: nunit-plugin
    • Labels:
    • Environment:
    • Similar Issues:

      Description

      After a period of 8 hours and 4 minutes the NUnit publisher is interrupted because the process takes too long.

      20:55:29 Archiving artifacts
      20:56:09 Recording NUnit tests results
      05:00:01 ERROR: Step ‘Publish NUnit test result report’ aborted due to exception: 
      05:00:01 java.lang.InterruptedException
      05:00:01 	at java.lang.Object.wait(Native Method)
      05:00:01 	at hudson.remoting.Request.call(Request.java:147)
      05:00:01 	at hudson.remoting.Channel.call(Channel.java:829)
      05:00:01 	at hudson.FilePath.act(FilePath.java:986)
      05:00:01 	at hudson.FilePath.act(FilePath.java:975)
      05:00:01 	at hudson.FilePath.deleteRecursive(FilePath.java:1177)
      05:00:01 	at hudson.plugins.nunit.NUnitPublisher.perform(NUnitPublisher.java:277)
      05:00:01 	at hudson.tasks.BuildStepCompatibilityLayer.perform(BuildStepCompatibilityLayer.java:81)
      05:00:01 	at hudson.tasks.BuildStepMonitor$1.perform(BuildStepMonitor.java:20)
      05:00:01 	at hudson.model.AbstractBuild$AbstractBuildExecution.perform(AbstractBuild.java:735)
      05:00:01 	at hudson.model.AbstractBuild$AbstractBuildExecution.performAllBuildSteps(AbstractBuild.java:676)
      05:00:01 	at hudson.model.Build$BuildExecution.post2(Build.java:186)
      05:00:01 	at hudson.model.AbstractBuild$AbstractBuildExecution.post(AbstractBuild.java:621)
      05:00:01 	at hudson.model.Run.execute(Run.java:1760)
      05:00:01 	at hudson.model.FreeStyleBuild.run(FreeStyleBuild.java:43)
      05:00:01 	at hudson.model.ResourceController.execute(ResourceController.java:97)
      05:00:01 	at hudson.model.Executor.run(Executor.java:405)
      

      This happens after a build has failed. The .xml is around 163KB's large.

      I can't (yet) share the xml because it contains private company data of which I am not 100% sure if I would be allowed to share that information

        Attachments

          Activity

          slide_o_mix Alex Earl added a comment -

          Without the XML, there really isn't anything I can do.

          daantimmer Daan Timmer added a comment -

          Alex Earl They annoying thing is, I've copied the resulting xml and created a custom build that only does the nunit publishing and it succeeded 10 times in a row with the same xml.

          And looking at the stacktrace it doesn't appear to be going wrong with the .xml itself. Stack trace points to: https://github.com/jenkinsci/nunit-plugin/blob/master/src/main/java/hudson/plugins/nunit/NUnitPublisher.java#L277 from where on it stops working.

          Reaching that point parsing the xml has already succeeded and I also see the results on the build screen inside jenkins.

          slide_o_mix Alex Earl added a comment -

          The agent doesn't go offline or anything does it?

          daantimmer Daan Timmer added a comment -

          I have not seen any reboots/restarts or network resets.

           

          Also, expect little response from me the coming three weeks as I'll not be at the office. I'll be able to respond from home, but not with data from the work place.

          slide_o_mix Alex Earl added a comment -

          I haven't been able to reproduce this at all. If you have a way to reproduce it, please reopen and update the issue.


            People

            • Assignee:
              slide_o_mix Alex Earl
              Reporter:
              daantimmer Daan Timmer
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: