Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-45842

Add option to determine minimal Java level from API

    XMLWordPrintable

    Details

    • Similar Issues:

      Description

      Currently there is no way to understand what is the minimal required version in Jenkins core and plugins.

      So I propose to add new API, which would help for tickets like JENKINS-29412.

        Attachments

          Issue Links

            Activity

            Hide
            oleg_nenashev Oleg Nenashev added a comment -

            Just to clarify, the "in plugins" means that plugin can use the API to understand which Java version to require for external cases (Like Java in SSH slaves). In this ticket I have no plan to consult with plugin metadata in order to adjust the minimal required version.

            Seems it confused Daniel Beck at least.

            Show
            oleg_nenashev Oleg Nenashev added a comment - Just to clarify, the "in plugins" means that plugin can use the API to understand which Java version to require for external cases (Like Java in SSH slaves). In this ticket I have no plan to consult with plugin metadata in order to adjust the minimal required version. Seems it confused Daniel Beck at least.

              People

              • Assignee:
                oleg_nenashev Oleg Nenashev
                Reporter:
                oleg_nenashev Oleg Nenashev
              • Votes:
                0 Vote for this issue
                Watchers:
                1 Start watching this issue

                Dates

                • Created:
                  Updated: