Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-4590

hudson.dev.java.net availability impacts loading of pages with forms

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Critical
    • Resolution: Fixed
    • Component/s: core
    • Labels:
      None
    • Environment:
      Platform: All, OS: Linux
    • Similar Issues:
      Show 5 results

      Description

      When hudson.dev.java.net is Out, the task does not work.
      Today this occours, and than my Hudson instance return error saying that wait
      for a submit!!!!

      logs attached

        Attachments

          Activity

          abayer Andrew Bayer added a comment -

          Ok, my approach didn't work, so I'm kicking this to Kohsuke.

          kohsuke Kohsuke Kawaguchi added a comment -

          Update center fetch is inserted in a way that doesn't block the page completion
          event, so we can safely declare that it's not caused by the update center.

          Ditto for the usage statistics.

          That leaves tool lists.

          scm_issue_link SCM/JIRA link daemon added a comment -

          Code changed in hudson
          User: : kohsuke
          Path:
          trunk/hudson/main/core/src/main/java/hudson/model/DownloadService.java
          trunk/hudson/main/core/src/main/resources/hudson/model/UsageStatistics/footer.jelly
          trunk/www/changelog.html
          http://fisheye4.cenqua.com/changelog/hudson/?cs=22347
          Log:
          [FIXED JENKINS-4590] Defer injection of the script until the page load event fires, so that inability to load scripts from java.net wouldn't block other things that's wating for the firing of the onload event.

          kohsuke Kohsuke Kawaguchi added a comment -

          This fix will be in 1.327.

          scm_issue_link SCM/JIRA link daemon added a comment -

          Code changed in hudson
          User: : kohsuke
          Path:
          trunk/hudson/main/core/src/main/java/hudson/model/DownloadService.java
          http://fisheye4.cenqua.com/changelog/hudson/?cs=22348
          Log:
          JENKINS-4590 only send a request up to every once in 10 seconds in order to avoid hitting java.net too hard when it's about to recover from an outage.


            People

            • Assignee:
              kohsuke Kohsuke Kawaguchi
              Reporter:
              sberlotto sberlotto
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: