Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-45932

Cannot update jenkins server 2.46.3 to latest

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Resolved (View Workflow)
    • Priority: Major
    • Resolution: Not A Defect
    • Component/s: core
    • Labels:
      None
    • Environment:
    • Similar Issues:

      Description

      root@508438:~# apt-get install jenkins
      Reading package lists... Done
      Building dependency tree
      Reading state information... Done
      Some packages could not be installed. This may mean that you have
      requested an impossible situation or if you are using the unstable
      distribution that some required packages have not yet been created
      or been moved out of Incoming.
      The following information may help to resolve the situation:The following packages have unmet dependencies:
      jenkins : Depends: default-jre-headless (>= 2:1.8) but 2:1.7-52 is to be installed or
      java8-runtime-headless but it is not installable
      E: Unable to correct problems, you have held broken packages.

        Attachments

          Issue Links

            Activity

            Hide
            oleg_nenashev Oleg Nenashev added a comment -

            Not a defect. Jenkins 2.60.1+ requires Java 8. So you have to install a whatever Java 8 package which provides the Java metapackage. If you use Oracle JDK or whatever custom deployment, JENKINS-45287 is going to change the Java discovery logic in next releases.

            Show
            oleg_nenashev Oleg Nenashev added a comment - Not a defect. Jenkins 2.60.1+ requires Java 8. So you have to install a whatever Java 8 package which provides the Java metapackage. If you use Oracle JDK or whatever custom deployment, JENKINS-45287 is going to change the Java discovery logic in next releases.
            Hide
            oleg_nenashev Oleg Nenashev added a comment -
            Show
            oleg_nenashev Oleg Nenashev added a comment - CC Raul Arabaolaza
            Hide
            donatas_luciunas Donatas Lučiūnas added a comment -

            thank you for explanation.

            Show
            donatas_luciunas Donatas Lučiūnas added a comment - thank you for explanation.
            Hide
            rarabaolaza Raul Arabaolaza added a comment -

            Fully agree with Oleg Nenashev, the package needs Java 8 but your system is unable to resolve and install the required java 8 packages automatically

            Yes, after JENKINS-45287 the package itself is not going to enforce any Java version but the server will not run unless is able to find a valid java 8 version in the system, is up to users to properly install a Java 8 runtime

            Show
            rarabaolaza Raul Arabaolaza added a comment - Fully agree with Oleg Nenashev , the package needs Java 8 but your system is unable to resolve and install the required java 8 packages automatically Yes, after JENKINS-45287 the package itself is not going to enforce any Java version but the server will not run unless is able to find a valid java 8 version in the system, is up to users to properly install a Java 8 runtime

              People

              • Assignee:
                Unassigned
                Reporter:
                donatas_luciunas Donatas Lučiūnas
              • Votes:
                0 Vote for this issue
                Watchers:
                3 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: