Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-4598

Dependency configuration between matrix projects not working properly

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Duplicate
    • Component/s: matrix-project-plugin
    • Labels:
      None
    • Environment:
      Platform: All, OS: All
    • Similar Issues:

      Description

      Hello,

      I create a project A with one axis called 'platform' and one value p1.
      I then add a project B with the same 'platform' axis and value p1.
      I would like to build B whenever A has been built, regardless of the axis involved.

      The straightforward approaches don't work :
      . adding A in "Build after other projects are built" for B seems valid but after
      saving and coming back to the configuration page the text box is empty
      . adding B in "Build other projects" for A does the exact same thing
      And of course neither B appears as a downstream project on A page, nor the opposite.

      Now if I add A/platform=p1 in "Build after other projects are built" for B then
      A (and not A/platform=p1) appears as an upstream project on B project page.
      When I go back to B configuration page however the "Build after other projects
      are built" field displays A (and not A/platform=p1) and then saving the page
      yields to the removal of the dependency...

      Thanks !
      MAT.

        Attachments

          Issue Links

            Activity

            mat007 mat007 added a comment -

            Sorry, it seems that this actually makes it possible to set the dependency :
            . adding B in "Build other projects" for A
            A then appears correctly in B configuration inside "Build after other projects
            are built" but gets removed when saving B.

            MAT.

            mdonohue mdonohue added a comment -

            This is the second most voted matrix issue right now - issue 3607

                • This issue has been marked as a duplicate of 3607 ***

              People

              • Assignee:
                Unassigned
                Reporter:
                mat007 mat007
              • Votes:
                0 Vote for this issue
                Watchers:
                0 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: