Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-46215

Restarting a Windows slave causes the master to shutdown

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Major
    • Resolution: Done
    • Component/s: core
    • Labels:
    • Environment:
      master Ubuntu 16.04.2 LTS
      slave Windows 7 64bit
    • Similar Issues:

      Description

      When we restart or connect a Windows slave, the master shuts down. This doesn't happen consistently, but now that we are restarting the slaves over night, the master is down pretty much every morning.

      The master log just says:

      Aug 16, 2017 4:41:48 AM winstone.Logger logInternal
      INFO: JVM is terminating. Shutting down Winstone
      

      No exception or other error.

      We had this issue for some time which happened sporadically, when connecting a Windows slave.

      Our Windows slaves are on Windows 7 64bit and uses the Jenkins agent installed as a service. When we restart the machine, the node is not brought temporary offline, that is, it goes offline because the slave is disconnected, then comes back online by itself. I wonder is that could be an issue?

      How can I get more information on why the JVM is shutting down?

        Attachments

          Activity

          oleg_nenashev Oleg Nenashev added a comment -

          No idea, I have tried to reproduce it ~1 week ago, no success.

          mviargues Maxime Viargues added a comment -

          Shame It happened again this morning, that's quite annoying now I am scared to just bring a node online and crash the system. Is there a way to get more information on why it shuts down? More loggin or something?

          oleg_nenashev Oleg Nenashev added a comment -

          Let's start from the full System log. Maybe JVM is crashing in an elegant way. Ideally you could just install a Support Core plugin and upload the entire bundle, maybe we will discover something there

          mviargues Maxime Viargues added a comment -

          Ok I'll do that and send it when I've got it crashed again.

          mviargues Maxime Viargues added a comment -

          Well good news I've found the problem... quite anticlimactic though. It was due to one of our plugin, that we forked from the diskcheck plugin. The version we forked from had a System.exit(0) in the code on a very edge case that was only happening when the slave didn't have disk information, which was the case when the slave was connecting for the first time. Fortunately I saw the build log when it happened.

          Such a waste of time... but anyway I am glad it's fixed.

          Thanks for your help.


            People

            • Assignee:
              Unassigned
              Reporter:
              mviargues Maxime Viargues
            • Votes:
              0 Vote for this issue
              Watchers:
              3 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: