Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-46245

Not showing "Running on node name" inside stage

    XMLWordPrintable

    Details

    • Similar Issues:

      Description

      Currently you have to go back to Console Output or echo the same stuff inside your pipeline.
      Feel a bit counterproductive.

      Simplified pipeline 

      stage('iOS Build') {
        node('ios') {
          fastlane build
        }
      }

      Console output

      [Pipeline] [iOS build] node
      [iOS build] Running on VASOSXDEV20 in /Users/jenkins/slave/workspace/xamarin_PR-142-LCK3VHNE4ZTFZ4JFZHITY4MB5KUNJ7QHA6CX7RHTT62XDO2OZ55A
      [Pipeline] [Android build] node
      [Android build] Running on VASOSXDEV19 in /Users/jenkins/workspace/xamarin_PR-142-LCK3VHNE4ZTFZ4JFZHITY4MB5KUNJ7QHA6CX7RHTT62XDO2OZ55A
      [Pipeline] [Unit Tests] node
      [Unit Tests] Running on VASOSXDEV18 in /Users/jenkins/workspace/xamarin_PR-142-LCK3VHNE4ZTFZ4JFZHITY4MB5KUNJ7QHA6CX7RHTT62XDO2OZ55A

      Would like to see it added as the first step in any stage view

      Like this:

        Attachments

          Issue Links

            Activity

            casz Joseph Petersen created issue -
            casz Joseph Petersen made changes -
            Field Original Value New Value
            Description Currently you have to go back to Console Output or echo the same stuff inside your pipeline.
            Feel a bit counterproductive.

            Simplified pipeline
             
            {code:java}
            stage('iOS Build') {
              node('ios') {
                fastlane build
              }
            }{code}

            Console output
            [Pipeline] [iOS build] node*00:00:04.172* [iOS build] Running on VASOSXDEV20 in /Users/jenkins/slave/workspace/xamarin_PR-142-LCK3VHNE4ZTFZ4JFZHITY4MB5KUNJ7QHA6CX7RHTT62XDO2OZ55A
            [Pipeline] [Android build] node*00:00:04.188* [Android build] Running on VASOSXDEV19 in /Users/jenkins/workspace/xamarin_PR-142-LCK3VHNE4ZTFZ4JFZHITY4MB5KUNJ7QHA6CX7RHTT62XDO2OZ55A
            [Pipeline] [Unit Tests] node*00:00:04.360* [Unit Tests] Running on VASOSXDEV18 in /Users/jenkins/workspace/xamarin_PR-142-LCK3VHNE4ZTFZ4JFZHITY4MB5KUNJ7QHA6CX7RHTT62XDO2OZ55A
            Currently you have to go back to Console Output or echo the same stuff inside your pipeline.
             Feel a bit counterproductive.

            Simplified pipeline
              
            {code:java}
            stage('iOS Build') {
              node('ios') {
                fastlane build
              }
            }{code}
            Console output
            {code:java}
            [Pipeline] [iOS build] node*00:00:04.172* [iOS build] Running on VASOSXDEV20 in /Users/jenkins/slave/workspace/xamarin_PR-142-LCK3VHNE4ZTFZ4JFZHITY4MB5KUNJ7QHA6CX7RHTT62XDO2OZ55A
             [Pipeline] [Android build] node*00:00:04.188* [Android build] Running on VASOSXDEV19 in /Users/jenkins/workspace/xamarin_PR-142-LCK3VHNE4ZTFZ4JFZHITY4MB5KUNJ7QHA6CX7RHTT62XDO2OZ55A
             [Pipeline] [Unit Tests] node*00:00:04.360* [Unit Tests] Running on VASOSXDEV18 in /Users/jenkins/workspace/xamarin_PR-142-LCK3VHNE4ZTFZ4JFZHITY4MB5KUNJ7QHA6CX7RHTT62XDO2OZ55A{code}
            casz Joseph Petersen made changes -
            Description Currently you have to go back to Console Output or echo the same stuff inside your pipeline.
             Feel a bit counterproductive.

            Simplified pipeline
              
            {code:java}
            stage('iOS Build') {
              node('ios') {
                fastlane build
              }
            }{code}
            Console output
            {code:java}
            [Pipeline] [iOS build] node*00:00:04.172* [iOS build] Running on VASOSXDEV20 in /Users/jenkins/slave/workspace/xamarin_PR-142-LCK3VHNE4ZTFZ4JFZHITY4MB5KUNJ7QHA6CX7RHTT62XDO2OZ55A
             [Pipeline] [Android build] node*00:00:04.188* [Android build] Running on VASOSXDEV19 in /Users/jenkins/workspace/xamarin_PR-142-LCK3VHNE4ZTFZ4JFZHITY4MB5KUNJ7QHA6CX7RHTT62XDO2OZ55A
             [Pipeline] [Unit Tests] node*00:00:04.360* [Unit Tests] Running on VASOSXDEV18 in /Users/jenkins/workspace/xamarin_PR-142-LCK3VHNE4ZTFZ4JFZHITY4MB5KUNJ7QHA6CX7RHTT62XDO2OZ55A{code}
            Currently you have to go back to Console Output or echo the same stuff inside your pipeline.
             Feel a bit counterproductive.

            Simplified pipeline
              
            {code:java}
            stage('iOS Build') {
              node('ios') {
                fastlane build
              }
            }{code}
            Console output
            {code:java}
            [Pipeline] [iOS build] node
            [iOS build] Running on VASOSXDEV20 in /Users/jenkins/slave/workspace/xamarin_PR-142-LCK3VHNE4ZTFZ4JFZHITY4MB5KUNJ7QHA6CX7RHTT62XDO2OZ55A
            [Pipeline] [Android build] node
            [Android build] Running on VASOSXDEV19 in /Users/jenkins/workspace/xamarin_PR-142-LCK3VHNE4ZTFZ4JFZHITY4MB5KUNJ7QHA6CX7RHTT62XDO2OZ55A
            [Pipeline] [Unit Tests] node
            [Unit Tests] Running on VASOSXDEV18 in /Users/jenkins/workspace/xamarin_PR-142-LCK3VHNE4ZTFZ4JFZHITY4MB5KUNJ7QHA6CX7RHTT62XDO2OZ55A{code}
            casz Joseph Petersen made changes -
            Attachment image-2017-08-16-18-12-48-045.png [ 39301 ]
            casz Joseph Petersen made changes -
            Description Currently you have to go back to Console Output or echo the same stuff inside your pipeline.
             Feel a bit counterproductive.

            Simplified pipeline
              
            {code:java}
            stage('iOS Build') {
              node('ios') {
                fastlane build
              }
            }{code}
            Console output
            {code:java}
            [Pipeline] [iOS build] node
            [iOS build] Running on VASOSXDEV20 in /Users/jenkins/slave/workspace/xamarin_PR-142-LCK3VHNE4ZTFZ4JFZHITY4MB5KUNJ7QHA6CX7RHTT62XDO2OZ55A
            [Pipeline] [Android build] node
            [Android build] Running on VASOSXDEV19 in /Users/jenkins/workspace/xamarin_PR-142-LCK3VHNE4ZTFZ4JFZHITY4MB5KUNJ7QHA6CX7RHTT62XDO2OZ55A
            [Pipeline] [Unit Tests] node
            [Unit Tests] Running on VASOSXDEV18 in /Users/jenkins/workspace/xamarin_PR-142-LCK3VHNE4ZTFZ4JFZHITY4MB5KUNJ7QHA6CX7RHTT62XDO2OZ55A{code}
            Currently you have to go back to Console Output or echo the same stuff inside your pipeline.
             Feel a bit counterproductive.

            Simplified pipeline 
            {code:java}
            stage('iOS Build') {
              node('ios') {
                fastlane build
              }
            }{code}
            Console output
            {code:java}
            [Pipeline] [iOS build] node
            [iOS build] Running on VASOSXDEV20 in /Users/jenkins/slave/workspace/xamarin_PR-142-LCK3VHNE4ZTFZ4JFZHITY4MB5KUNJ7QHA6CX7RHTT62XDO2OZ55A
            [Pipeline] [Android build] node
            [Android build] Running on VASOSXDEV19 in /Users/jenkins/workspace/xamarin_PR-142-LCK3VHNE4ZTFZ4JFZHITY4MB5KUNJ7QHA6CX7RHTT62XDO2OZ55A
            [Pipeline] [Unit Tests] node
            [Unit Tests] Running on VASOSXDEV18 in /Users/jenkins/workspace/xamarin_PR-142-LCK3VHNE4ZTFZ4JFZHITY4MB5KUNJ7QHA6CX7RHTT62XDO2OZ55A{code}

            Would like to see it added as the first step in any stage view
            !image-2017-08-16-18-12-48-045.png!
            casz Joseph Petersen made changes -
            Description Currently you have to go back to Console Output or echo the same stuff inside your pipeline.
             Feel a bit counterproductive.

            Simplified pipeline 
            {code:java}
            stage('iOS Build') {
              node('ios') {
                fastlane build
              }
            }{code}
            Console output
            {code:java}
            [Pipeline] [iOS build] node
            [iOS build] Running on VASOSXDEV20 in /Users/jenkins/slave/workspace/xamarin_PR-142-LCK3VHNE4ZTFZ4JFZHITY4MB5KUNJ7QHA6CX7RHTT62XDO2OZ55A
            [Pipeline] [Android build] node
            [Android build] Running on VASOSXDEV19 in /Users/jenkins/workspace/xamarin_PR-142-LCK3VHNE4ZTFZ4JFZHITY4MB5KUNJ7QHA6CX7RHTT62XDO2OZ55A
            [Pipeline] [Unit Tests] node
            [Unit Tests] Running on VASOSXDEV18 in /Users/jenkins/workspace/xamarin_PR-142-LCK3VHNE4ZTFZ4JFZHITY4MB5KUNJ7QHA6CX7RHTT62XDO2OZ55A{code}

            Would like to see it added as the first step in any stage view
            !image-2017-08-16-18-12-48-045.png!
            Currently you have to go back to Console Output or echo the same stuff inside your pipeline.
             Feel a bit counterproductive.

            Simplified pipeline 
            {code:java}
            stage('iOS Build') {
              node('ios') {
                fastlane build
              }
            }{code}
            Console output
            {code:java}
            [Pipeline] [iOS build] node
            [iOS build] Running on VASOSXDEV20 in /Users/jenkins/slave/workspace/xamarin_PR-142-LCK3VHNE4ZTFZ4JFZHITY4MB5KUNJ7QHA6CX7RHTT62XDO2OZ55A
            [Pipeline] [Android build] node
            [Android build] Running on VASOSXDEV19 in /Users/jenkins/workspace/xamarin_PR-142-LCK3VHNE4ZTFZ4JFZHITY4MB5KUNJ7QHA6CX7RHTT62XDO2OZ55A
            [Pipeline] [Unit Tests] node
            [Unit Tests] Running on VASOSXDEV18 in /Users/jenkins/workspace/xamarin_PR-142-LCK3VHNE4ZTFZ4JFZHITY4MB5KUNJ7QHA6CX7RHTT62XDO2OZ55A{code}
            Would like to see it added as the first step in any stage view
             !image-2017-08-16-18-12-48-045.png!

            Like this:
            !image-2017-08-16-18-27-37-265.png!
            Attachment image-2017-08-16-18-27-37-265.png [ 39302 ]
            jamesdumay James Dumay added a comment -

            This is a duplicate of JENKINS-44981. Its on the plan to fix soon, so check back shortly

            jamesdumay James Dumay made changes -
            Link This issue duplicates JENKINS-44981 [ JENKINS-44981 ]
            jamesdumay James Dumay made changes -
            Status Open [ 1 ] Resolved [ 5 ]
            Resolution Duplicate [ 3 ]
            casz Joseph Petersen added a comment -

            James Dumay it's still not in


              People

              • Assignee:
                Unassigned
                Reporter:
                casz Joseph Petersen
              • Votes:
                0 Vote for this issue
                Watchers:
                2 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: