Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-46302

Unable to load class once the loading was interrupted

    Details

    • Similar Issues:

      Description

      I was looking -JENKINS-36991- as the error seems to be related but the stack trace is different.

      The issue might not be related at all or it relates to the git or bitbucket plugin? Please let me know if you need any more information... 

      Started by user Michael Henke
       [EnvInject] - Loading node environment variables.
       Building remotely on Windows (VisualStudio2015 VisualStudio2017) in workspace C:\Jenkins\workspace\<redacted>.Win8
       > git rev-parse --is-inside-work-tree # timeout=10
       Fetching changes from the remote Git repository
       > git config remote.origin.url https://bitbucket.org/<redacted>/<redacted>.mobile.git # timeout=10
       Fetching upstream changes from https://bitbucket.org/<redacted>/<redacted>.mobile.git
       > git --version # timeout=10
       using GIT_ASKPASS to set credentials <redacted> Bitbucket Account
       > git fetch --no-tags --progress https://bitbucket.org/<redacted>/<redacted>.mobile.git +refs/heads/:refs/remotes/origin/ --depth=1
       > git rev-parse "refs/remotes/origin/develop^
      {commit}" # timeout=10
       > git rev-parse "refs/remotes/origin/origin/develop^{commit}
      " # timeout=10
       Checking out Revision <redacted> (refs/remotes/origin/develop)
       java.lang.NoClassDefFoundError: Could not initialize class jenkins.model.Jenkins$MasterComputer
       at org.jenkinsci.plugins.gitclient.AbstractGitAPIImpl.withRepository(AbstractGitAPIImpl.java:29)
       at org.jenkinsci.plugins.gitclient.CliGitAPIImpl.withRepository(CliGitAPIImpl.java:71)
       at sun.reflect.GeneratedMethodAccessor39.invoke(Unknown Source)
       at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
       at java.lang.reflect.Method.invoke(Unknown Source)
       at hudson.remoting.RemoteInvocationHandler$RPCRequest.perform(RemoteInvocationHandler.java:896)
       at hudson.remoting.RemoteInvocationHandler$RPCRequest.call(RemoteInvocationHandler.java:870)
       at hudson.remoting.RemoteInvocationHandler$RPCRequest.call(RemoteInvocationHandler.java:829)
       at hudson.remoting.UserRequest.perform(UserRequest.java:181)
       at hudson.remoting.UserRequest.perform(UserRequest.java:52)
       at hudson.remoting.Request$2.run(Request.java:336)
       at hudson.remoting.InterceptingExecutorService$1.call(InterceptingExecutorService.java:68)
       at java.util.concurrent.FutureTask.run(Unknown Source)
       at java.util.concurrent.ThreadPoolExecutor.runWorker(Unknown Source)
       at java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source)
       at hudson.remoting.Engine$1$1.run(Engine.java:98)
       at java.lang.Thread.run(Unknown Source)
       at ......remote call to JNLP4-connect connection from my.meraki.net/192.168.128.1:35905(Native Method)
       at hudson.remoting.Channel.attachCallSiteStackTrace(Channel.java:1554)
       at hudson.remoting.UserResponse.retrieve(UserRequest.java:281)
       at hudson.remoting.Channel.call(Channel.java:839)
       Caused: java.io.IOException: Remote call on JNLP4-connect connection from my.meraki.net/192.168.128.1:35905 failed
       at hudson.remoting.Channel.call(Channel.java:847)
       at hudson.remoting.RemoteInvocationHandler.invoke(RemoteInvocationHandler.java:257)
       at com.sun.proxy.$Proxy108.withRepository(Unknown Source)
       at org.jenkinsci.plugins.gitclient.RemoteGitImpl.withRepository(RemoteGitImpl.java:235)
       at hudson.plugins.git.GitSCM.printCommitMessageToLog(GitSCM.java:1195)
       at hudson.plugins.git.GitSCM.checkout(GitSCM.java:1159)
       at hudson.scm.SCM.checkout(SCM.java:495)
       at hudson.model.AbstractProject.checkout(AbstractProject.java:1212)
       at hudson.model.AbstractBuild$AbstractBuildExecution.defaultCheckout(AbstractBuild.java:566)
       at jenkins.scm.SCMCheckoutStrategy.checkout(SCMCheckoutStrategy.java:86)
       at hudson.model.AbstractBuild$AbstractBuildExecution.run(AbstractBuild.java:491)
       at hudson.model.Run.execute(Run.java:1739)
       at hudson.model.FreeStyleBuild.run(FreeStyleBuild.java:43)
       at hudson.model.ResourceController.execute(ResourceController.java:97)
       at hudson.model.Executor.run(Executor.java:419)
       Retrying after 10 seconds
      

       

        Attachments

          Activity

          Hide
          markewaite Mark Waite added a comment - - edited

          Can you confirm that the agent where this is failing is running Java 8? Java 7 is not supported for agents with Jenkins 2.54 and later.

          I removed the git plugin from the list of components even though the stack trace includes the git client plugin because those two plugins rely on the remoting facilities.

          Show
          markewaite Mark Waite added a comment - - edited Can you confirm that the agent where this is failing is running Java 8? Java 7 is not supported for agents with Jenkins 2.54 and later. I removed the git plugin from the list of components even though the stack trace includes the git client plugin because those two plugins rely on the remoting facilities.
          Hide
          aphex3k Michael Henke added a comment -

          I can confirm I'm running Java 8 on this box.

          Show
          aphex3k Michael Henke added a comment - I can confirm I'm running Java 8 on this box.
          Hide
          markewaite Mark Waite added a comment -

          Can you duplicate the problem in a different environment?

          Are there specific areas where this installation might be atypical, things that might be different than others?

          Show
          markewaite Mark Waite added a comment - Can you duplicate the problem in a different environment? Are there specific areas where this installation might be atypical, things that might be different than others?
          Hide
          aphex3k Michael Henke added a comment -

          I had this working for over a week and then it stopped working all of a sudden. I didn't even change the job configuration...

          Show
          aphex3k Michael Henke added a comment - I had this working for over a week and then it stopped working all of a sudden. I didn't even change the job configuration...
          Hide
          aphex3k Michael Henke added a comment -

          Mark Waite, please feel free to close the issue. I rebooted the machine running the slave-agent and the next time I executed a remote job on it, the error was gone...

          Show
          aphex3k Michael Henke added a comment - Mark Waite , please feel free to close the issue. I rebooted the machine running the slave-agent and the next time I executed a remote job on it, the error was gone...

            People

            • Assignee:
              Unassigned
              Reporter:
              aphex3k Michael Henke
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: