Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-46610

Use Java 8 constructs to improve codebase

    Details

    • Type: Bug
    • Status: Open
    • Priority: Minor
    • Resolution: Unresolved
    • Component/s: core
    • Labels:
      None
    • Similar Issues:

      Description

      This is sort of an umbrella issue.

      Now Java 8 is required to run Jenkins, we can improve core codebase to rely on new constructs (default methodes, lambdas, etc). 

        Attachments

          Activity

            People

            • Assignee:
              Unassigned
              Reporter:
              ndeloof Nicolas De Loof
            • Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated: